# CVE-2020-15115: No minimum password length in etcd

> etcd allows weak passwords without length validation, enabling attackers to easily guess or brute-force credentials to gain unauthorized access.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Aug 2020
- **Updated:** 4 Aug 2024
- **Also known as:** AZL-6392, DEBIAN-CVE-2020-15115, GHSA-4993-m7g5-r9hh, UBUNTU-CVE-2020-15115

## What is CVE-2020-15115?

CVE-2020-15115 is a medium-severity vulnerability in Fedoraproject Fedora, published on 6 Aug 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

etcd before versions 3.3.23 and 3.4.10 does not perform any password length validation, which allows for very short passwords, such as those with a length of one. This may allow an attacker to guess or brute-force users' passwords with little computational effort.

Weakness: CWE-521 (Weak Password Requirements)

## Which versions are affected by CVE-2020-15115?

4 open source packages ship an affected version, including go.etcd.io/etcd/client/v3. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `go.etcd.io/etcd/client/v3` | Go | All versions | 3.3.23 |
| `go.etcd.io/etcd/client/v3` | Go | All versions | 3.3.23 |
| `go.etcd.io/etcd/client/v3` | Go | From 3.4.0 | 3.4.10 |
| `go.etcd.io/etcd/client/v3` | Go | From 3.4.0 | 3.4.10 |

Products: Fedoraproject Fedora, Redhat Etcd.

## How do I fix CVE-2020-15115?

Upgrade go.etcd.io/etcd/client/v3 to a fixed version for your release line: 3.3.23 or 3.4.10.

## Is CVE-2020-15115 being exploited?

There is no known exploitation of CVE-2020-15115 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2024-4577](https://insights.sbomify.com/CVE-2024-4577/): PHP-CGI OS Command Injection (critical 9.8, exploited in the wild)
- [CVE-2021-39226](https://insights.sbomify.com/CVE-2021-39226/): Grafana Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2019-5544](https://insights.sbomify.com/CVE-2019-5544/): VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2024-4947](https://insights.sbomify.com/CVE-2024-4947/): Google Chromium V8 Type Confusion (critical 9.6, exploited in the wild)
- [CVE-2024-4671](https://insights.sbomify.com/CVE-2024-4671/): Google Chromium Visuals Use-After-Free (critical 9.6, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15115 and fix it if it is affected.

What it is: CVE-2020-15115 is a medium-severity vulnerability in Fedoraproject Fedora, published on 6 Aug 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-15115 in the wild and no public exploit code.

Affected packages and fixed versions:
- go.etcd.io/etcd/client/v3 (Go): affected all versions; fixed in 3.3.23
- go.etcd.io/etcd/client/v3 (Go): affected all versions; fixed in 3.3.23
- go.etcd.io/etcd/client/v3 (Go): affected from 3.4.0; fixed in 3.4.10
- go.etcd.io/etcd/client/v3 (Go): affected from 3.4.0; fixed in 3.4.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15115/ (Markdown: https://insights.sbomify.com/CVE-2020-15115/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15115
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15115
- OSV: https://osv.dev/vulnerability/CVE-2020-15115

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15115/
Summaries are generated and may contain mistakes; the official description above is the record.
