{"answers":{"affected":"5 open source packages ship an affected version, including wagtail. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-15118 in the wild and no public exploit code.","fix":"Upgrade wagtail to a fixed version for your release line: 2.7.4 or 2.9.3.","what":"CVE-2020-15118 is a medium-severity cross-site scripting vulnerability in wagtail, published on 20 Jul 2020. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-15118 and fix it if it is affected.\n\nWhat it is: CVE-2020-15118 is a medium-severity cross-site scripting vulnerability in wagtail, published on 20 Jul 2020. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-15118 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- wagtail (PyPI): affected all versions; fixed in 2.7.4\n- wagtail (PyPI): affected all versions; fixed in 2.7.4\n- wagtail (PyPI): affected from 2.7; fixed in 2.7.4, 2.9.3\n- wagtail (PyPI): affected from 2.8rc1; fixed in 2.9.3\n- wagtail (PyPI): affected from 2.8rc1; fixed in 2.9.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-15118/ (Markdown: https://insights.sbomify.com/CVE-2020-15118/index.md)","id":"CVE-2020-15118","markdown":"https://insights.sbomify.com/CVE-2020-15118/index.md","name":"CVE-2020-15118","record":{"aliases":["GHSA-2473-9hgq-j7xw","PYSEC-2020-154"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"Wagtail CMS","requires_auth":"high_privilege","summary":"Wagtail editors can inject HTML into form help text, leading to cross-site scripting and potential privilege escalation for site visitors.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"wagtail","vendor":"torchbox"}],"cvss":{"score":5.7,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"In Wagtail before versions 2.7.4 and 2.9.3, when a form page type is made available to Wagtail editors through the `wagtail.contrib.forms` app, and the page template is built using Django's standard form rendering helpers such as form.as_p, any HTML tags used within a form field's help text will be rendered unescaped in the page. Allowing HTML within help text is an intentional design decision by Django; however, as a matter of policy Wagtail does not allow editors to insert arbitrary HTML by default, as this could potentially be used to carry out cross-site scripting attacks, including privilege escalation. This functionality should therefore not have been made available to editor-level users. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. Patched versions have been released as Wagtail 2.7.4 (for the LTS 2.7 branch) and Wagtail 2.9.3 (for the current 2.9 branch). In these versions, help text will be escaped to prevent the inclusion of HTML tags. Site owners who wish to re-enable the use of HTML within help text (and are willing to accept the risk of this being exploited by editors) may set WAGTAILFORMS_HELP_TEXT_ALLOW_HTML = True in their configuration settings. Site owners who are unable to upgrade to the new versions can secure their form page templates by rendering forms field-by-field as per Django's documentation, but omitting the |safe filter when outputting the help text.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-Site Scripting in Wagtail","id":"CVE-2020-15118","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":5,"n_references":5,"next":{"headline":"DOM-based XSS in auth0-lock","id":"CVE-2020-15119"},"packages":[{"ecosystem":"PyPI","fixed":["2.7.4"],"introduced":["0"],"last_affected":[],"package":"wagtail","purl":null,"source":"GHSA-2473-9hgq-j7xw"},{"ecosystem":"PyPI","fixed":["2.7.4"],"introduced":["0"],"last_affected":[],"package":"wagtail","purl":"pkg:pypi/wagtail","source":"GHSA-2473-9hgq-j7xw"},{"ecosystem":"PyPI","fixed":["2.7.4","2.9.3"],"introduced":["2.7","2.9"],"last_affected":[],"package":"wagtail","purl":"pkg:pypi/wagtail","source":"PYSEC-2020-154"},{"ecosystem":"PyPI","fixed":["2.9.3"],"introduced":["2.8rc1"],"last_affected":[],"package":"wagtail","purl":null,"source":"GHSA-2473-9hgq-j7xw"},{"ecosystem":"PyPI","fixed":["2.9.3"],"introduced":["2.8rc1"],"last_affected":[],"package":"wagtail","purl":"pkg:pypi/wagtail","source":"GHSA-2473-9hgq-j7xw"}],"prev":{"headline":"Denial of Service in Synergy","id":"CVE-2020-15117"},"products":["wagtail"],"published":"2020-07-20","related":[{"cvss_score":7.3,"headline":"Wagtail: Reflected XSS in dynamic image URL generator view","id":"CVE-2026-54263","kev_date_added":null,"published":"2026-07-01"},{"cvss_score":6.5,"headline":"Wagtail: Improper permission handling in image preview","id":"CVE-2026-54261","kev_date_added":null,"published":"2026-07-01"},{"cvss_score":6.5,"headline":"Wagtail: Improper permission handling when comparing revisions","id":"CVE-2026-44197","kev_date_added":null,"published":"2026-05-11"},{"cvss_score":6.5,"headline":"Wagtail: Improper permission handling when deleting form submissions","id":"CVE-2026-44199","kev_date_added":null,"published":"2026-05-11"},{"cvss_score":6.5,"headline":"Wagtail: Improper permission handling when copying pages","id":"CVE-2026-44200","kev_date_added":null,"published":"2026-05-11"},{"cvss_score":6.5,"headline":"Wagtail regular expression denial-of-service via search query parsing","id":"CVE-2024-39317","kev_date_added":null,"published":"2024-07-11"},{"cvss_score":6.4,"headline":"Wagtail vulnerable to stored Cross-site Scripting attack via ModelAdmin views","id":"CVE-2023-28836","kev_date_added":null,"published":"2023-04-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["wagtail"]},"summary":"Wagtail editors can inject HTML into form help text, leading to cross-site scripting and potential privilege escalation for site visitors.","url":"https://insights.sbomify.com/CVE-2020-15118/"}