# CVE-2020-15118: Cross-Site Scripting in Wagtail

> Wagtail editors can inject HTML into form help text, leading to cross-site scripting and potential privilege escalation for site visitors.

- **Severity:** Medium 5.7 (`CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-2473-9hgq-j7xw, PYSEC-2020-154

## What is CVE-2020-15118?

CVE-2020-15118 is a medium-severity cross-site scripting vulnerability in wagtail, published on 20 Jul 2020. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

In Wagtail before versions 2.7.4 and 2.9.3, when a form page type is made available to Wagtail editors through the `wagtail.contrib.forms` app, and the page template is built using Django's standard form rendering helpers such as form.as_p, any HTML tags used within a form field's help text will be rendered unescaped in the page. Allowing HTML within help text is an intentional design decision by Django; however, as a matter of policy Wagtail does not allow editors to insert arbitrary HTML by default, as this could potentially be used to carry out cross-site scripting attacks, including privilege escalation. This functionality should therefore not have been made available to editor-level users. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin. Patched versions have been released as Wagtail 2.7.4 (for the LTS 2.7 branch) and Wagtail 2.9.3 (for the current 2.9 branch). In these versions, help text will be escaped to prevent the inclusion of HTML tags. Site owners who wish to re-enable the use of HTML within help text (and are willing to accept the risk of this being exploited by editors) may set WAGTAILFORMS_HELP_TEXT_ALLOW_HTML = True in their configuration settings. Site owners who are unable to upgrade to the new versions can secure their form page templates by rendering forms field-by-field as per Django's documentation, but omitting the |safe filter when outputting the help text.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-15118?

5 open source packages ship an affected version, including wagtail. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wagtail` | PyPI | All versions | 2.7.4 |
| `wagtail` | PyPI | All versions | 2.7.4 |
| `wagtail` | PyPI | From 2.7 | 2.7.4, 2.9.3 |
| `wagtail` | PyPI | From 2.8rc1 | 2.9.3 |
| `wagtail` | PyPI | From 2.8rc1 | 2.9.3 |

Products: Torchbox Wagtail.

## How do I fix CVE-2020-15118?

Upgrade wagtail to a fixed version for your release line: 2.7.4 or 2.9.3.

## Is CVE-2020-15118 being exploited?

There is no known exploitation of CVE-2020-15118 in the wild and no public exploit code.

## Other vulnerabilities in wagtail

- [CVE-2026-54263](https://insights.sbomify.com/CVE-2026-54263/): Wagtail: Reflected XSS in dynamic image URL generator view (high 7.3)
- [CVE-2026-54261](https://insights.sbomify.com/CVE-2026-54261/): Wagtail: Improper permission handling in image preview (medium 6.5)
- [CVE-2026-44197](https://insights.sbomify.com/CVE-2026-44197/): Wagtail: Improper permission handling when comparing revisions (medium 6.5)
- [CVE-2026-44199](https://insights.sbomify.com/CVE-2026-44199/): Wagtail: Improper permission handling when deleting form submissions (medium 6.5)
- [CVE-2026-44200](https://insights.sbomify.com/CVE-2026-44200/): Wagtail: Improper permission handling when copying pages (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15118 and fix it if it is affected.

What it is: CVE-2020-15118 is a medium-severity cross-site scripting vulnerability in wagtail, published on 20 Jul 2020. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-15118 in the wild and no public exploit code.

Affected packages and fixed versions:
- wagtail (PyPI): affected all versions; fixed in 2.7.4
- wagtail (PyPI): affected all versions; fixed in 2.7.4
- wagtail (PyPI): affected from 2.7; fixed in 2.7.4, 2.9.3
- wagtail (PyPI): affected from 2.8rc1; fixed in 2.9.3
- wagtail (PyPI): affected from 2.8rc1; fixed in 2.9.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15118/ (Markdown: https://insights.sbomify.com/CVE-2020-15118/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15118
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15118
- OSV: https://osv.dev/vulnerability/CVE-2020-15118

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15118/
Summaries are generated and may contain mistakes; the official description above is the record.
