{"answers":{"affected":"2 open source packages ship an affected version, including auth0-lock. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-15119 in the wild and no public exploit code.","fix":"Upgrade auth0-lock to 11.26.3 or later.","what":"CVE-2020-15119 is a medium-severity cross-site scripting vulnerability in auth0 lock, published on 19 Aug 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-15119 and fix it if it is affected.\n\nWhat it is: CVE-2020-15119 is a medium-severity cross-site scripting vulnerability in auth0 lock, published on 19 Aug 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-15119 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- auth0-lock (npm): affected all versions; fixed in 11.26.3\n- auth0-lock (npm): affected all versions; fixed in 11.26.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-15119/ (Markdown: https://insights.sbomify.com/CVE-2020-15119/index.md)","id":"CVE-2020-15119","markdown":"https://insights.sbomify.com/CVE-2020-15119/index.md","name":"CVE-2020-15119","record":{"aliases":["GHSA-6gg3-pmm7-97xc"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Auth0 Lock library","requires_auth":"low_privilege","summary":"An attacker can execute arbitrary scripts in the victim's browser via DOM-based XSS in the Auth0 Lock library.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"lock","vendor":"auth0"}],"cvss":{"score":6.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"In auth0-lock versions before and including 11.25.1, dangerouslySetInnerHTML is used to update the DOM. When dangerouslySetInnerHTML is used, the application and its users might be exposed to cross-site scripting (XSS) attacks.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"DOM-based XSS in auth0-lock","id":"CVE-2020-15119","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":2,"n_references":1,"next":{"headline":"Authorization Bypass in I hate money","id":"CVE-2020-15120"},"packages":[{"ecosystem":"npm","fixed":["11.26.3"],"introduced":["0"],"last_affected":[],"package":"auth0-lock","purl":null,"source":"GHSA-6gg3-pmm7-97xc"},{"ecosystem":"npm","fixed":["11.26.3"],"introduced":["0"],"last_affected":[],"package":"auth0-lock","purl":"pkg:npm/auth0-lock","source":"GHSA-6gg3-pmm7-97xc"}],"prev":{"headline":"Cross-Site Scripting in Wagtail","id":"CVE-2020-15118"},"products":["lock"],"published":"2020-08-19","related":[{"cvss_score":8.1,"headline":"Reflected XSS when using flashMessages","id":"CVE-2021-32641","kev_date_added":null,"published":"2021-06-04"},{"cvss_score":6.1,"headline":"HTML injection with additional signup fields","id":"CVE-2022-29172","kev_date_added":null,"published":"2022-05-05"},{"cvss_score":6.1,"headline":"auth0-lock vulnerable to XSS via unsanitized placeholder property","id":"CVE-2019-20174","kev_date_added":null,"published":"2020-02-03"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["auth0"]},"summary":"An attacker can execute arbitrary scripts in the victim's browser via DOM-based XSS in the Auth0 Lock library.","url":"https://insights.sbomify.com/CVE-2020-15119/"}