# CVE-2020-15119: DOM-based XSS in auth0-lock

> An attacker can execute arbitrary scripts in the victim's browser via DOM-based XSS in the Auth0 Lock library.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Aug 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-6gg3-pmm7-97xc

## What is CVE-2020-15119?

CVE-2020-15119 is a medium-severity cross-site scripting vulnerability in auth0 lock, published on 19 Aug 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In auth0-lock versions before and including 11.25.1, dangerouslySetInnerHTML is used to update the DOM. When dangerouslySetInnerHTML is used, the application and its users might be exposed to cross-site scripting (XSS) attacks.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-15119?

2 open source packages ship an affected version, including auth0-lock. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `auth0-lock` | npm | All versions | 11.26.3 |
| `auth0-lock` | npm | All versions | 11.26.3 |

Products: Auth0 Lock.

## How do I fix CVE-2020-15119?

Upgrade auth0-lock to 11.26.3 or later.

## Is CVE-2020-15119 being exploited?

There is no known exploitation of CVE-2020-15119 in the wild and no public exploit code.

## Other vulnerabilities in auth0 lock

- [CVE-2021-32641](https://insights.sbomify.com/CVE-2021-32641/): Reflected XSS when using flashMessages (high 8.1)
- [CVE-2022-29172](https://insights.sbomify.com/CVE-2022-29172/): HTML injection with additional signup fields (medium 6.1)
- [CVE-2019-20174](https://insights.sbomify.com/CVE-2019-20174/): auth0-lock vulnerable to XSS via unsanitized placeholder property (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15119 and fix it if it is affected.

What it is: CVE-2020-15119 is a medium-severity cross-site scripting vulnerability in auth0 lock, published on 19 Aug 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-15119 in the wild and no public exploit code.

Affected packages and fixed versions:
- auth0-lock (npm): affected all versions; fixed in 11.26.3
- auth0-lock (npm): affected all versions; fixed in 11.26.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15119/ (Markdown: https://insights.sbomify.com/CVE-2020-15119/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15119
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15119
- OSV: https://osv.dev/vulnerability/CVE-2020-15119

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15119/
Summaries are generated and may contain mistakes; the official description above is the record.
