# CVE-2020-15120: Authorization Bypass in I hate money

> Authenticated users can modify or delete members of other projects and access their bills without authorization, leading to data exposure and modification.

- **Severity:** Medium 4.9 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-67j9-c52g-w2q9, PYSEC-2020-264

## What is CVE-2020-15120?

CVE-2020-15120 is a medium-severity missing authorization vulnerability in spiral-project ihatemoney, published on 27 Jul 2020. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

In "I hate money" before version 4.1.5, an authenticated member of one project can modify and delete members of another project, without knowledge of this other project's private code. This can be further exploited to access all bills of another project without knowledge of this other project's private code. With the default configuration, anybody is allowed to create a new project. An attacker can create a new project and then use it to become authenticated and exploit this flaw. As such, the exposure is similar to an unauthenticated attack, because it is trivial to become authenticated. This is fixed in version 4.1.5.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2020-15120?

3 open source packages ship an affected version, including ihatemoney. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ihatemoney` | PyPI | All versions | 4.1.5 |
| `ihatemoney` | PyPI | All versions | 4.1.5 |
| `ihatemoney` | PyPI | All versions | 4.1.5 |

Products: Ihatemoney I Hate Money.

## How do I fix CVE-2020-15120?

Upgrade ihatemoney to 4.1.5 or later.

## Is CVE-2020-15120 being exploited?

There is no known exploitation of CVE-2020-15120 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15120 and fix it if it is affected.

What it is: CVE-2020-15120 is a medium-severity missing authorization vulnerability in spiral-project ihatemoney, published on 27 Jul 2020. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-15120 in the wild and no public exploit code.

Affected packages and fixed versions:
- ihatemoney (PyPI): affected all versions; fixed in 4.1.5
- ihatemoney (PyPI): affected all versions; fixed in 4.1.5
- ihatemoney (PyPI): affected all versions; fixed in 4.1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15120/ (Markdown: https://insights.sbomify.com/CVE-2020-15120/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15120
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15120
- OSV: https://osv.dev/vulnerability/CVE-2020-15120

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15120/
Summaries are generated and may contain mistakes; the official description above is the record.
