{"answers":{"affected":"2 open source packages ship an affected version, including auth0. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-15125 in the wild and no public exploit code.","fix":"Upgrade auth0 to 2.27.1 or later.","what":"CVE-2020-15125 is a high-severity vulnerability in node-auth0, published on 29 Jul 2020. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-15125 and fix it if it is affected.\n\nWhat it is: CVE-2020-15125 is a high-severity vulnerability in node-auth0, published on 29 Jul 2020. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-15125 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- auth0 (npm): affected all versions; fixed in 2.27.1\n- auth0 (npm): affected all versions; fixed in 2.27.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-15125/ (Markdown: https://insights.sbomify.com/CVE-2020-15125/index.md)","id":"CVE-2020-15125","markdown":"https://insights.sbomify.com/CVE-2020-15125/index.md","name":"CVE-2020-15125","record":{"aliases":["GHSA-5jpf-pj32-xx53"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js auth0 library","requires_auth":"low_privilege","summary":"Attackers can obtain bearer tokens from logs if the auth0 npm library is used in specific machine-to-machine configurations.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"auth0.js","vendor":"auth0"}],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-209","name":"Generation of Error Message Containing Sensitive Information"}],"description":"In auth0 (npm package) versions before 2.27.1, a DenyList of specific keys that should be sanitized from the request object contained in the error object is used. The key for Authorization header is not sanitized and in certain cases the Authorization header value can be logged exposing a bearer token. You are affected by this vulnerability if you are using the auth0 npm package, and you are using a Machine to Machine application authorized to use Auth0's management API","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Authorization header is not sanitized in an error object in auth0","id":"CVE-2020-15125","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"information_disclosure","year":"2020"},"n_packages":2,"n_references":4,"next":{"headline":"Information disclosure through Viewer query in parse-server","id":"CVE-2020-15126"},"packages":[{"ecosystem":"npm","fixed":["2.27.1"],"introduced":["0"],"last_affected":[],"package":"auth0","purl":null,"source":"GHSA-5jpf-pj32-xx53"},{"ecosystem":"npm","fixed":["2.27.1"],"introduced":["0"],"last_affected":[],"package":"auth0","purl":"pkg:npm/auth0","source":"GHSA-5jpf-pj32-xx53"}],"prev":{"headline":"Path traversal in Goobi viewer Core","id":"CVE-2020-15124"},"products":["node-auth0"],"published":"2020-07-29","related":[{"cvss_score":9.8,"headline":"Auth bypass in n/a","id":"CVE-2018-6873","kev_date_added":null,"published":"2018-04-04"},{"cvss_score":8.8,"headline":"Cross-Site Request Forgery (CSRF) in Auth0","id":"CVE-2018-6874","kev_date_added":null,"published":"2018-04-04"},{"cvss_score":8.8,"headline":"Auth0-js bypasses CSRF checks","id":"CVE-2018-7307","kev_date_added":null,"published":"2018-03-06"},{"cvss_score":7.5,"headline":"auth0-js Privilege Escalation Vulnerability","id":"CVE-2017-17068","kev_date_added":null,"published":"2017-12-06"},{"cvss_score":7.1,"headline":"Improper Permission Checking in Auth.js SDK","id":"CVE-2026-42280","kev_date_added":null,"published":"2026-05-27"},{"cvss_score":5.5,"headline":"Information disclosure through error object","id":"CVE-2020-5263","kev_date_added":null,"published":"2020-04-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["auth0"]},"summary":"Attackers can obtain bearer tokens from logs if the auth0 npm library is used in specific machine-to-machine configurations.","url":"https://insights.sbomify.com/CVE-2020-15125/"}