# CVE-2020-15127: Denial of service in Contour

> An unauthenticated attacker can shut down all Envoy instances via an exposed endpoint, causing a complete ingress data plane outage.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Aug 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-contour-2020-15127, GHSA-mjp8-x484-pm3r

## What is CVE-2020-15127?

CVE-2020-15127 is a high-severity missing authorization vulnerability in projectcontour contour, published on 5 Aug 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Contour ( Ingress controller for Kubernetes) before version 1.7.0, a bad actor can shut down all instances of Envoy, essentially killing the entire ingress data plane. GET requests to /shutdown on port 8090 of the Envoy pod initiate Envoy's shutdown procedure. The shutdown procedure includes flipping the readiness endpoint to false, which removes Envoy from the routing pool. When running Envoy (For example on the host network, pod spec hostNetwork=true), the shutdown manager's endpoint is accessible to anyone on the network that can reach the Kubernetes node that's running Envoy. There is no authentication in place that prevents a rogue actor on the network from shutting down Envoy via the shutdown manager endpoint. Successful exploitation of this issue will lead to bad actors shutting down all instances of Envoy, essentially killing the entire ingress data plane. This is fixed in version 1.7.0.

Weakness: CWE-306 (Missing Authentication for Critical Functionality)

## Which versions are affected by CVE-2020-15127?

1 open source package ship an affected version, including contour. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `contour` | Bitnami | All versions | 1.7.0 |

Products: Projectcontour Contour.

## How do I fix CVE-2020-15127?

Upgrade contour to 1.7.0 or later.

## Is CVE-2020-15127 being exploited?

There is no known exploitation of CVE-2020-15127 in the wild and no public exploit code.

## Other vulnerabilities in projectcontour contour

- [CVE-2024-36539](https://insights.sbomify.com/CVE-2024-36539/): Missing authorization in n/a (critical 9.8)
- [CVE-2021-32783](https://insights.sbomify.com/CVE-2021-32783/): Authorization bypass in Contour (high 8.5)
- [CVE-2026-41246](https://insights.sbomify.com/CVE-2026-41246/): Contour: Lua code injection via Cookie Path Rewrite Policy (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15127 and fix it if it is affected.

What it is: CVE-2020-15127 is a high-severity missing authorization vulnerability in projectcontour contour, published on 5 Aug 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-15127 in the wild and no public exploit code.

Affected packages and fixed versions:
- contour (Bitnami): affected all versions; fixed in 1.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15127/ (Markdown: https://insights.sbomify.com/CVE-2020-15127/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15127
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15127
- OSV: https://osv.dev/vulnerability/CVE-2020-15127

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15127/
Summaries are generated and may contain mistakes; the official description above is the record.
