# CVE-2020-15131: False-positive validity for NFT1 genesis transactions in SLP Validate

> Attackers can create invalid NFT1 child tokens without burning group tokens due to flawed validation logic in the SLP Validate library.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jul 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-6jmr-jfh7-xg3h

## What is CVE-2020-15131?

CVE-2020-15131 is a high-severity vulnerability in simpleledger slp-validate.js, published on 30 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In SLP Validate (npm package slp-validate) before version 1.2.2, there is a vulnerability to false-positive validation outcomes for the NFT1 Child Genesis transaction type. A poorly implemented SLP wallet or opportunistic attacker could create a seemingly valid NFT1 child token without burning any of the NFT1 Group token type as is required by the NFT1 specification. This is fixed in version 1.2.2.

Weakness: CWE-697 (Incorrect Comparison)

## Which versions are affected by CVE-2020-15131?

2 open source packages ship an affected version, including slp-validate. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `slp-validate` | npm | All versions | 1.2.2 |
| `slp-validate` | npm | All versions | 1.2.2 |

Products: Simpleledger Slp-Validate.

## How do I fix CVE-2020-15131?

Upgrade slp-validate to 1.2.2 or later.

## Is CVE-2020-15131 being exploited?

There is no known exploitation of CVE-2020-15131 in the wild and no public exploit code.

## Other vulnerabilities in simpleledger slp-validate.js

- [CVE-2020-11072](https://insights.sbomify.com/CVE-2020-11072/): False-negative validation results in MINT transactions with invalid baton (high 8.6)
- [CVE-2019-16761](https://insights.sbomify.com/CVE-2019-16761/): Validator parsing discrepancy due to string encoding in NPM slp-validate 1.0.0 (medium 5.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15131 and fix it if it is affected.

What it is: CVE-2020-15131 is a high-severity vulnerability in simpleledger slp-validate.js, published on 30 Jul 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-15131 in the wild and no public exploit code.

Affected packages and fixed versions:
- slp-validate (npm): affected all versions; fixed in 1.2.2
- slp-validate (npm): affected all versions; fixed in 1.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15131/ (Markdown: https://insights.sbomify.com/CVE-2020-15131/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15131
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15131
- OSV: https://osv.dev/vulnerability/CVE-2020-15131

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15131/
Summaries are generated and may contain mistakes; the official description above is the record.
