# CVE-2020-15132: Reset Password / Login vulnerability in Sulu

> Attackers can enumerate valid usernames and retrieve email addresses via the password reset feature due to verbose error messages and response data.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 5 Aug 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-wfm4-pq59-wg6r

## What is CVE-2020-15132?

CVE-2020-15132 is a medium-severity vulnerability in sulu, published on 5 Aug 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Sulu before versions 1.6.35, 2.0.10, and 2.1.1, when the "Forget password" feature on the login screen is used, Sulu asks the user for a username or email address. If the given string is not found, a response with a `400` error code is returned, along with a error message saying that this user name does not exist. This enables attackers to retrieve valid usernames. Also, the response of the "Forgot Password" request returns the email address to which the email was sent, if the operation was successful. This information should not be exposed, as it can be used to gather email addresses. This problem was fixed in versions 1.6.35, 2.0.10 and 2.1.1.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2020-15132?

6 open source packages ship an affected version, including sulu/sulu. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sulu/sulu` | Packagist | All versions | 1.6.34 |
| `sulu/sulu` | Packagist | All versions | 1.6.34 |
| `sulu/sulu` | Packagist | From 2.0.0 | 2.0.10 |
| `sulu/sulu` | Packagist | From 2.0.0 | 2.0.10 |
| `sulu/sulu` | Packagist | From 2.1.0 | 2.1.1 |
| `sulu/sulu` | Packagist | From 2.1.0 | 2.1.1 |

Products: Sulu Sulu.

## How do I fix CVE-2020-15132?

Upgrade sulu/sulu to a fixed version for your release line: 1.6.34, 2.0.10 or 2.1.1.

## Is CVE-2020-15132 being exploited?

There is no known exploitation of CVE-2020-15132 in the wild and no public exploit code.

## Other vulnerabilities in sulu

- [CVE-2021-43836](https://insights.sbomify.com/CVE-2021-43836/): PHP file inclusion in the Sulu admin panel (high 8.5)
- [CVE-2021-32737](https://insights.sbomify.com/CVE-2021-32737/): XSS Injection in Media Collection Title was possible (high 8.4)
- [CVE-2021-43835](https://insights.sbomify.com/CVE-2021-43835/): Privilege escalation in the Sulu Admin panel (high 7.2)
- [CVE-2024-27915](https://insights.sbomify.com/CVE-2024-27915/): Sulu grants access to pages regardless of role permissions (medium 6.8)
- [CVE-2021-41169](https://insights.sbomify.com/CVE-2021-41169/): Improper Neutralization HTML tags in sulu/sulu (medium 6.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15132 and fix it if it is affected.

What it is: CVE-2020-15132 is a medium-severity vulnerability in sulu, published on 5 Aug 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-15132 in the wild and no public exploit code.

Affected packages and fixed versions:
- sulu/sulu (Packagist): affected all versions; fixed in 1.6.34
- sulu/sulu (Packagist): affected all versions; fixed in 1.6.34
- sulu/sulu (Packagist): affected from 2.0.0; fixed in 2.0.10
- sulu/sulu (Packagist): affected from 2.0.0; fixed in 2.0.10
- sulu/sulu (Packagist): affected from 2.1.0; fixed in 2.1.1
- sulu/sulu (Packagist): affected from 2.1.0; fixed in 2.1.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15132/ (Markdown: https://insights.sbomify.com/CVE-2020-15132/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15132
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15132
- OSV: https://osv.dev/vulnerability/CVE-2020-15132

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15132/
Summaries are generated and may contain mistakes; the official description above is the record.
