{"answers":{"affected":"2 open source packages ship an affected version, including faye. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-15134 in the wild and no public exploit code.","fix":"Upgrade faye to 1.4.0 or later.","what":"CVE-2020-15134 is a high-severity vulnerability in faye, published on 31 Jul 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-15134 and fix it if it is affected.\n\nWhat it is: CVE-2020-15134 is a high-severity vulnerability in faye, published on 31 Jul 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-15134 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- faye (RubyGems): affected all versions; fixed in 1.4.0\n- faye (RubyGems): affected all versions; fixed in 1.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-15134/ (Markdown: https://insights.sbomify.com/CVE-2020-15134/index.md)","id":"CVE-2020-15134","markdown":"https://insights.sbomify.com/CVE-2020-15134/index.md","name":"CVE-2020-15134","record":{"aliases":["DEBIAN-CVE-2020-15134","GHSA-3q49-h8f9-9fr9","UBUNTU-CVE-2020-15134"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby Faye library","requires_auth":"none","summary":"Faye library fails to verify TLS certificates, allowing man-in-the-middle attacks to intercept or modify data during WebSocket connections.","user_interaction":"required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"faye","vendor":"faye_project"}],"cvss":{"score":8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"Faye before version 1.4.0, there is a lack of certification validation in TLS handshakes. Faye uses em-http-request and faye-websocket in the Ruby version of its client. Those libraries both use the `EM::Connection#start_tls` method in EventMachine to implement the TLS handshake whenever a `wss:` URL is used for the connection. This method does not implement certificate verification by default, meaning that it does not check that the server presents a valid and trusted TLS certificate for the expected hostname. That means that any `https:` or `wss:` connection made using these libraries is vulnerable to a man-in-the-middle attack, since it does not confirm the identity of the server it is connected to. The first request a Faye client makes is always sent via normal HTTP, but later messages may be sent via WebSocket. Therefore it is vulnerable to the same problem that these underlying libraries are, and we needed both libraries to support TLS verification before Faye could claim to do the same. Your client would still be insecure if its initial HTTPS request was verified, but later WebSocket connections were not. This is fixed in Faye v1.4.0, which enables verification by default. For further background information on this issue, please see the referenced GitHub Advisory.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Missing TLS certificate verification in Faye","id":"CVE-2020-15134","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"security_feature_bypass","year":"2020"},"n_packages":2,"n_references":2,"next":{"headline":"CSRF vulnerability in save-server","id":"CVE-2020-15135"},"packages":[{"ecosystem":"RubyGems","fixed":["1.4.0"],"introduced":["0"],"last_affected":[],"package":"faye","purl":null,"source":"GHSA-3q49-h8f9-9fr9"},{"ecosystem":"RubyGems","fixed":["1.4.0"],"introduced":["0"],"last_affected":[],"package":"faye","purl":"pkg:gem/faye","source":"GHSA-3q49-h8f9-9fr9"}],"prev":{"headline":"Missing TLS certificate verification in Faye Websocket","id":"CVE-2020-15133"},"products":["faye"],"published":"2020-07-31","related":[{"cvss_score":8.5,"headline":"Authentication and extension bypass in Faye","id":"CVE-2020-11020","kev_date_added":null,"published":"2020-04-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["faye"]},"summary":"Faye library fails to verify TLS certificates, allowing man-in-the-middle attacks to intercept or modify data during WebSocket connections.","url":"https://insights.sbomify.com/CVE-2020-15134/"}