CVE-2020-15135 CSRF vulnerability in save-server

Medium 6.7 Published Updated

Attackers can force logged-in users to upload, delete files, or modify user accounts via CSRF, potentially leading to privilege escalation and data exposure.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2020-15135?

CVE-2020-15135 is a medium-severity vulnerability in Neztore save-server, published on 4 Aug 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

save-server (npm package) before version 1.05 is affected by a CSRF vulnerability, as there is no CSRF mitigation (Tokens etc.). The fix introduced in version version 1.05 unintentionally breaks uploading so version v1.0.7 is the fixed version. This is patched by implementing Double submit. The CSRF attack would require you to navigate to a malicious site while you have an active session with Save-Server (Session key stored in cookies). The malicious user would then be able to perform some actions, including uploading/deleting files and adding redirects. If you are logged in as root, this attack is significantly more severe. They can in addition create, delete and update users. If they updated the password of a user, that user's files would then be available. If the root password is updated, all files would be visible if they logged in with the new password. Note that due to the same origin policy malicious actors cannot view the gallery or the response of any of the methods, nor be sure they succeeded. This issue has been patched in version 1.0.7.

Weakness: CWE-352

Which versions are affected by CVE-2020-15135?

2 open source packages ship an affected version, including save-server. It affects 1 product.

PackageAffectedFixed in
save-server npmAll versions1.0.7
save-server npmAll versions1.0.7

Products include Save-Server Project Save-Server.

How do I fix CVE-2020-15135?

Upgrade save-server to 1.0.7 or later.

Is CVE-2020-15135 being exploited?

There is no known exploitation of CVE-2020-15135 in the wild and no public exploit code.

Sources

Also known as GHSA-wwrj-35w6-77ff.

Is CVE-2020-15135 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free