{"answers":{"affected":"2 open source packages ship an affected version, including save-server. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-15135 in the wild and no public exploit code.","fix":"Upgrade save-server to 1.0.7 or later.","what":"CVE-2020-15135 is a medium-severity vulnerability in Neztore save-server, published on 4 Aug 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-15135 and fix it if it is affected.\n\nWhat it is: CVE-2020-15135 is a medium-severity vulnerability in Neztore save-server, published on 4 Aug 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-15135 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- save-server (npm): affected all versions; fixed in 1.0.7\n- save-server (npm): affected all versions; fixed in 1.0.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-15135/ (Markdown: https://insights.sbomify.com/CVE-2020-15135/index.md)","id":"CVE-2020-15135","markdown":"https://insights.sbomify.com/CVE-2020-15135/index.md","name":"CVE-2020-15135","record":{"aliases":["GHSA-wwrj-35w6-77ff"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["data_modify","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"save-server npm package","requires_auth":"low_privilege","summary":"Attackers can force logged-in users to upload, delete files, or modify user accounts via CSRF, potentially leading to privilege escalation and data exposure.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"save-server","vendor":"save-server_project"}],"cvss":{"score":6.7,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:H/I:H/A:L","version":"3.1"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"save-server (npm package) before version 1.05 is affected by a CSRF vulnerability, as there is no CSRF mitigation (Tokens etc.). The fix introduced in version version 1.05 unintentionally breaks uploading so version v1.0.7 is the fixed version. This is patched by implementing Double submit. The CSRF attack would require you to navigate to a malicious site while you have an active session with Save-Server (Session key stored in cookies). The malicious user would then be able to perform some actions, including uploading/deleting files and adding redirects. If you are logged in as root, this attack is significantly more severe. They can in addition create, delete and update users. If they updated the password of a user, that user's files would then be available. If the root password is updated, all files would be visible if they logged in with the new password. Note that due to the same origin policy malicious actors cannot view the gallery or the response of any of the methods, nor be sure they succeeded. This issue has been patched in version 1.0.7.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CSRF vulnerability in save-server","id":"CVE-2020-15135","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"csrf","year":"2020"},"n_packages":2,"n_references":3,"next":{"headline":"Improper authentication in etcd","id":"CVE-2020-15136"},"packages":[{"ecosystem":"npm","fixed":["1.0.7"],"introduced":["0"],"last_affected":[],"package":"save-server","purl":null,"source":"GHSA-wwrj-35w6-77ff"},{"ecosystem":"npm","fixed":["1.0.7"],"introduced":["0"],"last_affected":[],"package":"save-server","purl":"pkg:npm/save-server","source":"GHSA-wwrj-35w6-77ff"}],"prev":{"headline":"Missing TLS certificate verification in Faye","id":"CVE-2020-15134"},"products":["save-server"],"published":"2020-08-04","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["Neztore"]},"summary":"Attackers can force logged-in users to upload, delete files, or modify user accounts via CSRF, potentially leading to privilege escalation and data exposure.","url":"https://insights.sbomify.com/CVE-2020-15135/"}