{"answers":{"affected":"2 open source packages ship an affected version, including prismjs. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-15138 in the wild and no public exploit code.","fix":"Upgrade prismjs to 1.21.0 or later.","what":"CVE-2020-15138 is a high-severity cross-site scripting vulnerability in PrismJS prism, published on 7 Aug 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-15138 and fix it if it is affected.\n\nWhat it is: CVE-2020-15138 is a high-severity cross-site scripting vulnerability in PrismJS prism, published on 7 Aug 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-15138 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- prismjs (npm): affected from 1.1.0; fixed in 1.21.0\n- prismjs (npm): affected from 1.1.0; fixed in 1.21.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-15138/ (Markdown: https://insights.sbomify.com/CVE-2020-15138/index.md)","id":"CVE-2020-15138","markdown":"https://insights.sbomify.com/CVE-2020-15138/index.md","name":"CVE-2020-15138","record":{"aliases":["DEBIAN-CVE-2020-15138","GHSA-wvhm-4hhf-97x9","ROOT-APP-NPM-CVE-2020-15138","UBUNTU-CVE-2020-15138"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"JavaScript syntax highlighter","requires_auth":"none","summary":"Attackers can execute arbitrary code in Safari and Internet Explorer via XSS in the Prism Previewers plugin easing preview.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"previewers","vendor":"prismjs"}],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Prism is vulnerable to Cross-Site Scripting. The easing preview of the Previewers plugin has an XSS vulnerability that allows attackers to execute arbitrary code in Safari and Internet Explorer. This impacts all Safari and Internet Explorer users of Prism \u003e=v1.1.0 that use the _Previewers_ plugin (\u003e=v1.10.0) or the _Previewer: Easing_ plugin (v1.1.0 to v1.9.0). This problem is fixed in version 1.21.0. To workaround the issue without upgrading, disable the easing preview on all impacted code blocks. You need Prism v1.10.0 or newer to apply this workaround.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-Site Scripting in Prism","id":"CVE-2020-15138","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"xss","year":"2020"},"n_packages":2,"n_references":3,"next":{"headline":"XSS in MyBB","id":"CVE-2020-15139"},"packages":[{"ecosystem":"npm","fixed":["1.21.0"],"introduced":["1.1.0"],"last_affected":[],"package":"prismjs","purl":null,"source":"GHSA-wvhm-4hhf-97x9"},{"ecosystem":"npm","fixed":["1.21.0"],"introduced":["1.1.0"],"last_affected":[],"package":"prismjs","purl":"pkg:npm/prismjs","source":"GHSA-wvhm-4hhf-97x9"}],"prev":{"headline":"Integer overflow in HoRNDIS","id":"CVE-2020-15137"},"products":["prism"],"published":"2020-08-07","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["PrismJS"]},"summary":"Attackers can execute arbitrary code in Safari and Internet Explorer via XSS in the Prism Previewers plugin easing preview.","url":"https://insights.sbomify.com/CVE-2020-15138/"}