# CVE-2020-15138: Cross-Site Scripting in Prism

> Attackers can execute arbitrary code in Safari and Internet Explorer via XSS in the Prism Previewers plugin easing preview.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Aug 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-15138, GHSA-wvhm-4hhf-97x9, ROOT-APP-NPM-CVE-2020-15138, UBUNTU-CVE-2020-15138

## What is CVE-2020-15138?

CVE-2020-15138 is a high-severity cross-site scripting vulnerability in PrismJS prism, published on 7 Aug 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Prism is vulnerable to Cross-Site Scripting. The easing preview of the Previewers plugin has an XSS vulnerability that allows attackers to execute arbitrary code in Safari and Internet Explorer. This impacts all Safari and Internet Explorer users of Prism >=v1.1.0 that use the _Previewers_ plugin (>=v1.10.0) or the _Previewer: Easing_ plugin (v1.1.0 to v1.9.0). This problem is fixed in version 1.21.0. To workaround the issue without upgrading, disable the easing preview on all impacted code blocks. You need Prism v1.10.0 or newer to apply this workaround.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-15138?

2 open source packages ship an affected version, including prismjs. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `prismjs` | npm | From 1.1.0 | 1.21.0 |
| `prismjs` | npm | From 1.1.0 | 1.21.0 |

Products: Prismjs Previewers.

## How do I fix CVE-2020-15138?

Upgrade prismjs to 1.21.0 or later.

## Is CVE-2020-15138 being exploited?

There is no known exploitation of CVE-2020-15138 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15138 and fix it if it is affected.

What it is: CVE-2020-15138 is a high-severity cross-site scripting vulnerability in PrismJS prism, published on 7 Aug 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-15138 in the wild and no public exploit code.

Affected packages and fixed versions:
- prismjs (npm): affected from 1.1.0; fixed in 1.21.0
- prismjs (npm): affected from 1.1.0; fixed in 1.21.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15138/ (Markdown: https://insights.sbomify.com/CVE-2020-15138/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15138
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15138
- OSV: https://osv.dev/vulnerability/CVE-2020-15138

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15138/
Summaries are generated and may contain mistakes; the official description above is the record.
