# CVE-2020-15141: Path Traversal in openapi-python-client

> Attackers can write files to arbitrary locations on disk by providing a malicious OpenAPI document to the client generator.

- **Severity:** Low 3.0 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Aug 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-7wgr-7666-7pwj, PYSEC-2020-70

## What is CVE-2020-15141?

CVE-2020-15141 is a low-severity path traversal vulnerability in triaxtec openapi-python-client, published on 14 Aug 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In openapi-python-client before version 0.5.3, there is a path traversal vulnerability. If a user generated a client using a maliciously crafted OpenAPI document, it is possible for generated files to be placed in arbitrary locations on disk.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2020-15141?

3 open source packages ship an affected version, including openapi-python-client. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openapi-python-client` | PyPI | All versions | 0.5.3 |
| `openapi-python-client` | PyPI | All versions | 0.5.3 |
| `openapi-python-client` | PyPI | All versions | 0.5.3 |

Products: Openapi-Python-Client Project Openapi-Python-Client.

## How do I fix CVE-2020-15141?

Upgrade openapi-python-client to 0.5.3 or later.

## Is CVE-2020-15141 being exploited?

There is no known exploitation of CVE-2020-15141 in the wild and no public exploit code.

## Other vulnerabilities in triaxtec openapi-python-client

- [CVE-2020-15142](https://insights.sbomify.com/CVE-2020-15142/): Arbitrary Code Generation (high 8.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15141 and fix it if it is affected.

What it is: CVE-2020-15141 is a low-severity path traversal vulnerability in triaxtec openapi-python-client, published on 14 Aug 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-15141 in the wild and no public exploit code.

Affected packages and fixed versions:
- openapi-python-client (PyPI): affected all versions; fixed in 0.5.3
- openapi-python-client (PyPI): affected all versions; fixed in 0.5.3
- openapi-python-client (PyPI): affected all versions; fixed in 0.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15141/ (Markdown: https://insights.sbomify.com/CVE-2020-15141/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15141
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15141
- OSV: https://osv.dev/vulnerability/CVE-2020-15141

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15141/
Summaries are generated and may contain mistakes; the official description above is the record.
