{"answers":{"affected":"3 open source packages ship an affected version, including openapi-python-client. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-15142 in the wild and no public exploit code.","fix":"Upgrade openapi-python-client to 0.5.3 or later.","what":"CVE-2020-15142 is a high-severity code injection vulnerability in triaxtec openapi-python-client, published on 14 Aug 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-15142 and fix it if it is affected.\n\nWhat it is: CVE-2020-15142 is a high-severity code injection vulnerability in triaxtec openapi-python-client, published on 14 Aug 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-15142 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openapi-python-client (PyPI): affected all versions; fixed in 0.5.3\n- openapi-python-client (PyPI): affected all versions; fixed in 0.5.3\n- openapi-python-client (PyPI): affected all versions; fixed in 0.5.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-15142/ (Markdown: https://insights.sbomify.com/CVE-2020-15142/index.md)","id":"CVE-2020-15142","markdown":"https://insights.sbomify.com/CVE-2020-15142/index.md","name":"CVE-2020-15142","record":{"aliases":["GHSA-9x4c-63pf-525f","PYSEC-2020-71"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Python OpenAPI client generator","requires_auth":"low_privilege","summary":"Attackers can achieve arbitrary code execution by crafting malicious OpenAPI documents that generate unsafe Python client code.","user_interaction":"required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"openapi-python-client","vendor":"openapi-python-client_project"}],"cvss":{"score":8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"In openapi-python-client before version 0.5.3, clients generated with a maliciously crafted OpenAPI Document can generate arbitrary Python code. Subsequent execution of this malicious client is arbitrary code execution.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Arbitrary Code Generation","id":"CVE-2020-15142","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"code_injection","year":"2020"},"n_packages":3,"n_references":4,"next":{"headline":"Remote Code Execution in SyliusResourceBundle","id":"CVE-2020-15143"},"packages":[{"ecosystem":"PyPI","fixed":["0.5.3"],"introduced":["0"],"last_affected":[],"package":"openapi-python-client","purl":null,"source":"GHSA-9x4c-63pf-525f"},{"ecosystem":"PyPI","fixed":["0.5.3"],"introduced":["0"],"last_affected":[],"package":"openapi-python-client","purl":"pkg:pypi/openapi-python-client","source":"GHSA-9x4c-63pf-525f"},{"ecosystem":"PyPI","fixed":["0.5.3"],"introduced":["0"],"last_affected":[],"package":"openapi-python-client","purl":"pkg:pypi/openapi-python-client","source":"PYSEC-2020-71"}],"prev":{"headline":"Path Traversal in openapi-python-client","id":"CVE-2020-15141"},"products":["openapi-python-client"],"published":"2020-08-14","related":[{"cvss_score":3,"headline":"Path Traversal in openapi-python-client","id":"CVE-2020-15141","kev_date_added":null,"published":"2020-08-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["triaxtec"]},"summary":"Attackers can achieve arbitrary code execution by crafting malicious OpenAPI documents that generate unsafe Python client code.","url":"https://insights.sbomify.com/CVE-2020-15142/"}