# CVE-2020-15142: Arbitrary Code Generation

> Attackers can achieve arbitrary code execution by crafting malicious OpenAPI documents that generate unsafe Python client code.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 14 Aug 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-9x4c-63pf-525f, PYSEC-2020-71

## What is CVE-2020-15142?

CVE-2020-15142 is a high-severity code injection vulnerability in triaxtec openapi-python-client, published on 14 Aug 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

In openapi-python-client before version 0.5.3, clients generated with a maliciously crafted OpenAPI Document can generate arbitrary Python code. Subsequent execution of this malicious client is arbitrary code execution.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2020-15142?

3 open source packages ship an affected version, including openapi-python-client. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openapi-python-client` | PyPI | All versions | 0.5.3 |
| `openapi-python-client` | PyPI | All versions | 0.5.3 |
| `openapi-python-client` | PyPI | All versions | 0.5.3 |

Products: Openapi-Python-Client Project Openapi-Python-Client.

## How do I fix CVE-2020-15142?

Upgrade openapi-python-client to 0.5.3 or later.

## Is CVE-2020-15142 being exploited?

There is no known exploitation of CVE-2020-15142 in the wild and no public exploit code.

## Other vulnerabilities in triaxtec openapi-python-client

- [CVE-2020-15141](https://insights.sbomify.com/CVE-2020-15141/): Path Traversal in openapi-python-client (low 3.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15142 and fix it if it is affected.

What it is: CVE-2020-15142 is a high-severity code injection vulnerability in triaxtec openapi-python-client, published on 14 Aug 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-15142 in the wild and no public exploit code.

Affected packages and fixed versions:
- openapi-python-client (PyPI): affected all versions; fixed in 0.5.3
- openapi-python-client (PyPI): affected all versions; fixed in 0.5.3
- openapi-python-client (PyPI): affected all versions; fixed in 0.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15142/ (Markdown: https://insights.sbomify.com/CVE-2020-15142/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15142
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15142
- OSV: https://osv.dev/vulnerability/CVE-2020-15142

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15142/
Summaries are generated and may contain mistakes; the official description above is the record.
