# CVE-2020-15148: Unsafe deserialization in Yii 2

> Remote code execution is possible in the Yii 2 framework if applications unsafely deserialize arbitrary user input.

- **Severity:** High 8.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-699q-wcff-g9mj

## What is CVE-2020-15148?

CVE-2020-15148 is a high-severity unsafe deserialization vulnerability in yiisoft yii2, published on 15 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Yii 2 (yiisoft/yii2) before version 2.0.38 is vulnerable to remote code execution if the application calls `unserialize()` on arbitrary user input. This is fixed in version 2.0.38. A possible workaround without upgrading is available in the linked advisory.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2020-15148?

2 open source packages ship an affected version, including yiisoft/yii2. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yiisoft/yii2` | Packagist | All versions | 2.0.38 |
| `yiisoft/yii2` | Packagist | All versions | 2.0.38 |

Products: Yiiframework Yii.

## How do I fix CVE-2020-15148?

Upgrade yiisoft/yii2 to 2.0.38 or later.

## Is CVE-2020-15148 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-15148 exists.

Public exploit code:

- 几条关于CVE-2020-15148（yii2反序列化）的绕过 (github_poc): https://github.com/Maskhe/CVE-2020-15148-bypasses
- cve-2020-15148 (github_poc): https://github.com/0xkami/cve-2020-15148
- Yii 2 < 2.0.38 - Remote Code Execution (nuclei): http/cves/2020/CVE-2020-15148.yaml

## Other vulnerabilities in yiisoft yii2

- [CVE-2024-58136](https://insights.sbomify.com/CVE-2024-58136/): Yiiframework Yii Improper Protection of Alternate Path (critical 9.0, exploited in the wild)
- [CVE-2015-5467](https://insights.sbomify.com/CVE-2015-5467/): Yii2 allows attackers to execute any local .php file via a relative path in the view parameter (critical 9.8)
- [CVE-2023-26750](https://insights.sbomify.com/CVE-2023-26750/): SQL injection in n/a (critical 9.8)
- [CVE-2018-7269](https://insights.sbomify.com/CVE-2018-7269/): Yii SQL injection vulnerability (critical 9.8)
- [CVE-2018-8073](https://insights.sbomify.com/CVE-2018-8073/): yii2-redis Potential Remote code execution (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15148 and fix it if it is affected.

What it is: CVE-2020-15148 is a high-severity unsafe deserialization vulnerability in yiisoft yii2, published on 15 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2020-15148 exists.

Affected packages and fixed versions:
- yiisoft/yii2 (Packagist): affected all versions; fixed in 2.0.38
- yiisoft/yii2 (Packagist): affected all versions; fixed in 2.0.38

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15148/ (Markdown: https://insights.sbomify.com/CVE-2020-15148/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15148
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15148
- OSV: https://osv.dev/vulnerability/CVE-2020-15148

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15148/
Summaries are generated and may contain mistakes; the official description above is the record.
