CVE-2020-15150 Remote Code Execution in paginator(hex)

Critical 9.0 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2020-15150?

CVE-2020-15150 is a critical vulnerability in duffelhq paginator, published on 1 Sep 2020.

Official description

There is a vulnerability in Paginator (Elixir/Hex package) which makes it susceptible to Remote Code Execution (RCE) attacks via input parameters to the paginate() function. This will potentially affect all current users of Paginator prior to version 1.0.0. The vulnerability has been patched in version 1.0.0 and all users should upgrade to this version immediately. Note that this patched version uses a dependency that requires an Elixir version >=1.5.

Weakness: CWE-94

Which versions are affected by CVE-2020-15150?

2 open source packages ship an affected version, including paginator. It affects 1 product.

PackageAffectedFixed in
paginator HexAll versions1.0.0
paginator HexAll versions1.0.0

Products include Duffel Paginator.

How do I fix CVE-2020-15150?

Upgrade paginator to 1.0.0 or later.

Is CVE-2020-15150 being exploited?

There is no known exploitation of CVE-2020-15150 in the wild and no public exploit code.

Sources

Also known as GHSA-w98m-2xqg-9cvj.

Is CVE-2020-15150 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free