CVE-2020-15151 Observable Timing Discrepancy in OpenMage LTS
Attackers can bypass CSRF protection in the Admin Interface via timing discrepancies, increasing the risk of Cross Site Request Forgery attacks.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-15151?
CVE-2020-15151 is a high-severity vulnerability in Magento Magento, published on 19 Aug 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
OpenMage LTS before versions 19.4.6 and 20.0.2 allows attackers to circumvent the `fromkey protection` in the Admin Interface and increases the attack surface for Cross Site Request Forgery attacks. This issue is related to Adobe's CVE-2020-9690. It is patched in versions 19.4.6 and 20.0.2.
Which versions are affected by CVE-2020-15151?
5 open source packages ship an affected version, including openmage/magento-lts and magento. It affects 2 products.
| Package | Affected | Fixed in |
|---|---|---|
openmage/magento-lts Packagist | All versions | 19.4.6 |
openmage/magento-lts Packagist | All versions | 19.4.6 |
openmage/magento-lts Packagist | From 20.0.0 | 20.0.2 |
openmage/magento-lts Packagist | From 20.0.0 | 20.0.2 |
magento Bitnami | All versions | 2.3.6 |
Products include Magento Magento, Openmage Openmage Long Term Support.
How do I fix CVE-2020-15151?
Upgrade openmage/magento-lts to a fixed version for your release line: 19.4.6 or 20.0.2.
Is CVE-2020-15151 being exploited?
There is no known exploitation of CVE-2020-15151 in the wild and no public exploit code.
Other vulnerabilities in Magento Magento
Sources
Also known as BIT-magento-2020-15151, GHSA-crf2-xm6x-46p6.