# CVE-2020-15151: Observable Timing Discrepancy in OpenMage LTS

> Attackers can bypass CSRF protection in the Admin Interface via timing discrepancies, increasing the risk of Cross Site Request Forgery attacks.

- **Severity:** High 8.0 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 19 Aug 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-magento-2020-15151, GHSA-crf2-xm6x-46p6

## What is CVE-2020-15151?

CVE-2020-15151 is a high-severity vulnerability in Magento Magento, published on 19 Aug 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

OpenMage LTS before versions 19.4.6 and 20.0.2 allows attackers to circumvent the `fromkey protection` in the Admin Interface and increases the attack surface for Cross Site Request Forgery attacks. This issue is related to Adobe's CVE-2020-9690. It is patched in versions 19.4.6 and 20.0.2.

Weakness: CWE-352 (Cross-Site Request Forgery), CWE-203 (Observable Discrepancy)

## Which versions are affected by CVE-2020-15151?

5 open source packages ship an affected version, including openmage/magento-lts and magento. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openmage/magento-lts` | Packagist | All versions | 19.4.6 |
| `openmage/magento-lts` | Packagist | All versions | 19.4.6 |
| `openmage/magento-lts` | Packagist | From 20.0.0 | 20.0.2 |
| `openmage/magento-lts` | Packagist | From 20.0.0 | 20.0.2 |
| `magento` | Bitnami | All versions | 2.3.6 |

Products: Magento Magento, Openmage Openmage Long Term Support.

## How do I fix CVE-2020-15151?

Upgrade openmage/magento-lts to a fixed version for your release line: 19.4.6 or 20.0.2.

## Is CVE-2020-15151 being exploited?

There is no known exploitation of CVE-2020-15151 in the wild and no public exploit code.

## Other vulnerabilities in Magento Magento

- [CVE-2020-9664](https://insights.sbomify.com/CVE-2020-9664/): Magento php object injection vulnerability (critical 9.8)
- [CVE-2020-9576](https://insights.sbomify.com/CVE-2020-9576/): Magento command injection vulnerability (critical 9.8)
- [CVE-2020-9578](https://insights.sbomify.com/CVE-2020-9578/): Magento command injection vulnerability (critical 9.8)
- [CVE-2020-9579](https://insights.sbomify.com/CVE-2020-9579/): Magento Security mitigation bypass vulnerability (critical 9.8)
- [CVE-2020-9580](https://insights.sbomify.com/CVE-2020-9580/): Magento Security mitigation bypass vulnerability (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15151 and fix it if it is affected.

What it is: CVE-2020-15151 is a high-severity vulnerability in Magento Magento, published on 19 Aug 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-15151 in the wild and no public exploit code.

Affected packages and fixed versions:
- openmage/magento-lts (Packagist): affected all versions; fixed in 19.4.6
- openmage/magento-lts (Packagist): affected all versions; fixed in 19.4.6
- openmage/magento-lts (Packagist): affected from 20.0.0; fixed in 20.0.2
- openmage/magento-lts (Packagist): affected from 20.0.0; fixed in 20.0.2
- magento (Bitnami): affected all versions; fixed in 2.3.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15151/ (Markdown: https://insights.sbomify.com/CVE-2020-15151/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15151
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15151
- OSV: https://osv.dev/vulnerability/CVE-2020-15151

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15151/
Summaries are generated and may contain mistakes; the official description above is the record.
