{"answers":{"affected":"6 open source packages ship an affected version, including ftp-srv. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-15152 in the wild and no public exploit code.","fix":"Upgrade ftp-srv to a fixed version for your release line: 2.19.6, 3.1.2 or 4.3.4.","what":"CVE-2020-15152 is a critical server-side request forgery vulnerability in autovance ftp-srv, published on 17 Aug 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-15152 and fix it if it is affected.\n\nWhat it is: CVE-2020-15152 is a critical server-side request forgery vulnerability in autovance ftp-srv, published on 17 Aug 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-15152 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ftp-srv (npm): affected from 1.0.0; fixed in 2.19.6\n- ftp-srv (npm): affected from 1.0.0; fixed in 2.19.6\n- ftp-srv (npm): affected from 3.0.0; fixed in 3.1.2\n- ftp-srv (npm): affected from 3.0.0; fixed in 3.1.2\n- ftp-srv (npm): affected from 4.0.0; fixed in 4.3.4\n- ftp-srv (npm): affected from 4.0.0; fixed in 4.3.4\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-15152/ (Markdown: https://insights.sbomify.com/CVE-2020-15152/index.md)","id":"CVE-2020-15152","markdown":"https://insights.sbomify.com/CVE-2020-15152/index.md","name":"CVE-2020-15152","record":{"aliases":["GHSA-jw37-5gqr-cf9j"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js FTP server","requires_auth":"none","summary":"An attacker can exploit the PORT command in the ftp-srv library to force the server to make arbitrary connections, enabling Server-Side Request Forgery attacks.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"ftp-srv","vendor":"ftp-srv_project"}],"cvss":{"score":9.1,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-918","name":"Server-Side Request Forgery"}],"description":"ftp-srv is an npm package which is a modern and extensible FTP server designed to be simple yet configurable. In ftp-srv before versions 2.19.6, 3.1.2, and 4.3.4 are vulnerable to Server-Side Request Forgery. The PORT command allows arbitrary IPs which can be used to cause the server to make a connection elsewhere. A possible workaround is blocking the PORT through the configuration. This issue is fixed in version2 2.19.6, 3.1.2, and 4.3.4. More information can be found on the linked advisory.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Server-Side Request Forgery in ftp-srv","id":"CVE-2020-15152","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"ssrf","year":"2020"},"n_packages":6,"n_references":3,"next":{"headline":"Unauthenticated SQL injection in Ampache","id":"CVE-2020-15153"},"packages":[{"ecosystem":"npm","fixed":["2.19.6"],"introduced":["1.0.0"],"last_affected":[],"package":"ftp-srv","purl":null,"source":"GHSA-jw37-5gqr-cf9j"},{"ecosystem":"npm","fixed":["2.19.6"],"introduced":["1.0.0"],"last_affected":[],"package":"ftp-srv","purl":"pkg:npm/ftp-srv","source":"GHSA-jw37-5gqr-cf9j"},{"ecosystem":"npm","fixed":["3.1.2"],"introduced":["3.0.0"],"last_affected":[],"package":"ftp-srv","purl":null,"source":"GHSA-jw37-5gqr-cf9j"},{"ecosystem":"npm","fixed":["3.1.2"],"introduced":["3.0.0"],"last_affected":[],"package":"ftp-srv","purl":"pkg:npm/ftp-srv","source":"GHSA-jw37-5gqr-cf9j"},{"ecosystem":"npm","fixed":["4.3.4"],"introduced":["4.0.0"],"last_affected":[],"package":"ftp-srv","purl":null,"source":"GHSA-jw37-5gqr-cf9j"},{"ecosystem":"npm","fixed":["4.3.4"],"introduced":["4.0.0"],"last_affected":[],"package":"ftp-srv","purl":"pkg:npm/ftp-srv","source":"GHSA-jw37-5gqr-cf9j"}],"prev":{"headline":"Observable Timing Discrepancy in OpenMage LTS","id":"CVE-2020-15151"},"products":["ftp-srv"],"published":"2020-08-17","related":[{"cvss_score":6.3,"headline":"File System Bounds Escape","id":"CVE-2020-26299","kev_date_added":null,"published":"2021-02-10"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["autovance"]},"summary":"An attacker can exploit the PORT command in the ftp-srv library to force the server to make arbitrary connections, enabling Server-Side Request Forgery attacks.","url":"https://insights.sbomify.com/CVE-2020-15152/"}