# CVE-2020-15152: Server-Side Request Forgery in ftp-srv

> An attacker can exploit the PORT command in the ftp-srv library to force the server to make arbitrary connections, enabling Server-Side Request Forgery attacks.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Aug 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-jw37-5gqr-cf9j

## What is CVE-2020-15152?

CVE-2020-15152 is a critical server-side request forgery vulnerability in autovance ftp-srv, published on 17 Aug 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

ftp-srv is an npm package which is a modern and extensible FTP server designed to be simple yet configurable. In ftp-srv before versions 2.19.6, 3.1.2, and 4.3.4 are vulnerable to Server-Side Request Forgery. The PORT command allows arbitrary IPs which can be used to cause the server to make a connection elsewhere. A possible workaround is blocking the PORT through the configuration. This issue is fixed in version2 2.19.6, 3.1.2, and 4.3.4. More information can be found on the linked advisory.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2020-15152?

6 open source packages ship an affected version, including ftp-srv. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ftp-srv` | npm | From 1.0.0 | 2.19.6 |
| `ftp-srv` | npm | From 1.0.0 | 2.19.6 |
| `ftp-srv` | npm | From 3.0.0 | 3.1.2 |
| `ftp-srv` | npm | From 3.0.0 | 3.1.2 |
| `ftp-srv` | npm | From 4.0.0 | 4.3.4 |
| `ftp-srv` | npm | From 4.0.0 | 4.3.4 |

Products: Ftp-Srv Project Ftp-Srv.

## How do I fix CVE-2020-15152?

Upgrade ftp-srv to a fixed version for your release line: 2.19.6, 3.1.2 or 4.3.4.

## Is CVE-2020-15152 being exploited?

There is no known exploitation of CVE-2020-15152 in the wild and no public exploit code.

## Other vulnerabilities in autovance ftp-srv

- [CVE-2020-26299](https://insights.sbomify.com/CVE-2020-26299/): File System Bounds Escape (medium 6.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15152 and fix it if it is affected.

What it is: CVE-2020-15152 is a critical server-side request forgery vulnerability in autovance ftp-srv, published on 17 Aug 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-15152 in the wild and no public exploit code.

Affected packages and fixed versions:
- ftp-srv (npm): affected from 1.0.0; fixed in 2.19.6
- ftp-srv (npm): affected from 1.0.0; fixed in 2.19.6
- ftp-srv (npm): affected from 3.0.0; fixed in 3.1.2
- ftp-srv (npm): affected from 3.0.0; fixed in 3.1.2
- ftp-srv (npm): affected from 4.0.0; fixed in 4.3.4
- ftp-srv (npm): affected from 4.0.0; fixed in 4.3.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15152/ (Markdown: https://insights.sbomify.com/CVE-2020-15152/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15152
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15152
- OSV: https://osv.dev/vulnerability/CVE-2020-15152

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15152/
Summaries are generated and may contain mistakes; the official description above is the record.
