CVE-2020-15155 Cross-Site Scripting in baserCMS

High 7.3 Published Updated

An attacker with admin access can execute arbitrary scripts via XSS in baserCMS, potentially compromising the site.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2020-15155?

CVE-2020-15155 is a high-severity cross-site scripting vulnerability in Basercms Basercms, published on 28 Aug 2020. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

baserCMS 4.3.6 and earlier is affected by Cross Site Scripting (XSS) via arbitrary script execution. Admin access is required to exploit this vulnerability. The affected components is toolbar.php. The issue is fixed in version 4.3.7.

Weakness: CWE-79

Which versions are affected by CVE-2020-15155?

2 open source packages ship an affected version, including baserproject/basercms. It affects 1 product.

PackageAffectedFixed in
baserproject/basercms PackagistFrom 4.0.04.3.7
baserproject/basercms PackagistFrom 4.0.04.3.7

Products include Basercms Basercms.

How do I fix CVE-2020-15155?

Upgrade baserproject/basercms to 4.3.7 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2020-15155 being exploited?

There is no known exploitation of CVE-2020-15155 in the wild and no public exploit code.

All Basercms Basercms vulnerabilities

Sources

Also known as GHSA-4r3m-j6x5-48m3.

Is CVE-2020-15155 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free