{"answers":{"affected":"2 open source packages ship an affected version, including baserproject/basercms. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-15155 in the wild and no public exploit code.","fix":"Upgrade baserproject/basercms to 4.3.7 or later.","what":"CVE-2020-15155 is a high-severity cross-site scripting vulnerability in Basercms Basercms, published on 28 Aug 2020. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-15155 and fix it if it is affected.\n\nWhat it is: CVE-2020-15155 is a high-severity cross-site scripting vulnerability in Basercms Basercms, published on 28 Aug 2020. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-15155 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- baserproject/basercms (Packagist): affected from 4.0.0; fixed in 4.3.7\n- baserproject/basercms (Packagist): affected from 4.0.0; fixed in 4.3.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-15155/ (Markdown: https://insights.sbomify.com/CVE-2020-15155/index.md)","id":"CVE-2020-15155","markdown":"https://insights.sbomify.com/CVE-2020-15155/index.md","name":"CVE-2020-15155","record":{"aliases":["GHSA-4r3m-j6x5-48m3"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"baserCMS","requires_auth":"high_privilege","summary":"An attacker with admin access can execute arbitrary scripts via XSS in baserCMS, potentially compromising the site.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"basercms","vendor":"basercms"}],"cvss":{"score":7.3,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"baserCMS 4.3.6 and earlier is affected by Cross Site Scripting (XSS) via arbitrary script execution. Admin access is required to exploit this vulnerability. The affected components is toolbar.php. The issue is fixed in version 4.3.7.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-Site Scripting in baserCMS","id":"CVE-2020-15155","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"basercms:basercms","products":["basercms:basercms"],"type":"xss","year":"2020"},"n_packages":2,"n_references":3,"next":{"headline":"XSS due to lack of CSRF validation for replying/publishing","id":"CVE-2020-15156"},"packages":[{"ecosystem":"Packagist","fixed":["4.3.7"],"introduced":["4.0.0"],"last_affected":[],"package":"baserproject/basercms","purl":null,"source":"GHSA-4r3m-j6x5-48m3"},{"ecosystem":"Packagist","fixed":["4.3.7"],"introduced":["4.0.0"],"last_affected":[],"package":"baserproject/basercms","purl":"pkg:composer/baserproject/basercms","source":"GHSA-4r3m-j6x5-48m3"}],"prev":{"headline":"Cross Site Scripting in baserCMS","id":"CVE-2020-15154"},"products":["basercms"],"published":"2020-08-28","related":[{"cvss_score":9.8,"headline":"baserCMS File Uploader Remote Code Execution (RCE) vulnerability","id":"CVE-2023-25654","kev_date_added":null,"published":"2023-03-23"},{"cvss_score":9.8,"headline":"baserCMS allows any file to be uploaded","id":"CVE-2023-25655","kev_date_added":null,"published":"2023-03-23"},{"cvss_score":9.8,"headline":"baserCMS SQL Injection vulnerability","id":"CVE-2017-10842","kev_date_added":null,"published":"2017-08-28"},{"cvss_score":9.2,"headline":"baserCMS: OS command injection vulnerability in installer","id":"CVE-2026-30880","kev_date_added":null,"published":"2026-03-31"},{"cvss_score":9.1,"headline":"baserCMS: OS Command Injection Leading to Remote Code Execution (RCE)","id":"CVE-2026-21861","kev_date_added":null,"published":"2026-03-31"},{"cvss_score":9.1,"headline":"baserCMS: OS Command Injection in the baserCMS Update Functionality","id":"CVE-2026-30877","kev_date_added":null,"published":"2026-03-31"},{"cvss_score":9.1,"headline":"OS Command Injection Vulnerability and Potential Zip Slip Vulnerability","id":"CVE-2021-41243","kev_date_added":null,"published":"2021-11-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["baserproject"]},"summary":"An attacker with admin access can execute arbitrary scripts via XSS in baserCMS, potentially compromising the site.","url":"https://insights.sbomify.com/CVE-2020-15155/"}