# CVE-2020-15156: XSS due to lack of CSRF validation for replying/publishing

> A logged-in user can be tricked into posting on their behalf due to missing CSRF validation in the NodeBB blog comments plugin.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Aug 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-43m5-c88r-cjvv

## What is CVE-2020-15156?

CVE-2020-15156 is a medium-severity vulnerability in psychobunny nodebb-plugin-blog-comments, published on 26 Aug 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In nodebb-plugin-blog-comments before version 0.7.0, a logged in user is vulnerable to an XSS attack which could allow a third party to post on their behalf on the forum. This is due to lack of CSRF validation.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2020-15156?

2 open source packages ship an affected version, including nodebb-plugin-blog-comments. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nodebb-plugin-blog-comments` | npm | All versions | 0.7.0 |
| `nodebb-plugin-blog-comments` | npm | All versions | 0.7.0 |

Products: Nodebb Blog Comments.

## How do I fix CVE-2020-15156?

Upgrade nodebb-plugin-blog-comments to 0.7.0 or later.

## Is CVE-2020-15156 being exploited?

There is no known exploitation of CVE-2020-15156 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15156 and fix it if it is affected.

What it is: CVE-2020-15156 is a medium-severity vulnerability in psychobunny nodebb-plugin-blog-comments, published on 26 Aug 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-15156 in the wild and no public exploit code.

Affected packages and fixed versions:
- nodebb-plugin-blog-comments (npm): affected all versions; fixed in 0.7.0
- nodebb-plugin-blog-comments (npm): affected all versions; fixed in 0.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15156/ (Markdown: https://insights.sbomify.com/CVE-2020-15156/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15156
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15156
- OSV: https://osv.dev/vulnerability/CVE-2020-15156

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15156/
Summaries are generated and may contain mistakes; the official description above is the record.
