CVE-2020-15157 containerd can be coerced into leaking credentials during image pull
Attackers can steal registry or cloud credentials by tricking users into pulling malicious container images with foreign layer URLs.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2020-15157?
CVE-2020-15157 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 16 Oct 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
In containerd (an industry-standard container runtime) before version 1.2.14 there is a credential leaking vulnerability. If a container image manifest in the OCI Image format or Docker Image V2 Schema 2 format includes a URL for the location of a specific image layer (otherwise known as a “foreign layer”), the default containerd resolver will follow that URL to attempt to download it. In v1.2.x but not 1.3.0 or later, the default containerd resolver will provide its authentication credentials if the server where the URL is located presents an HTTP 401 status code along with registry-specific HTTP headers. If an attacker publishes a public image with a manifest that directs one of the layers to be fetched from a web server they control and they trick a user or system into pulling the image, they can obtain the credentials used for pulling that image. In some cases, this may be the user's username and password for the registry. In other cases, this may be the credentials attached to the cloud virtual instance which can grant access to other cloud resources in the account. The default containerd resolver is used by the cri-containerd plugin (which can be used by Kubernetes), the ctr development tool, and other client programs that have explicitly linked against it. This vulnerability has been fixed in containerd 1.2.14. containerd 1.3 and later are not affected. If you are using containerd 1.3 or later, you are not affected. If you are using cri-containerd in the 1.2 series or prior, you should ensure you only pull images from trusted sources. Other container runtimes built on top of containerd but not using the default resolver (such as Docker) are not affected.
Weakness: CWE-522
Which versions are affected by CVE-2020-15157?
3 open source packages ship an affected version, including github.com/containerd/containerd. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
github.com/containerd/containerd Go | All versions | 1.2.14 |
github.com/containerd/containerd Go | All versions | 1.2.14 |
github.com/containerd/containerd Go | All versions | 1.2.14 |
Products include Canonical Ubuntu Linux, Debian Debian Linux, Linuxfoundation Containerd.
How do I fix CVE-2020-15157?
Upgrade github.com/containerd/containerd to 1.2.14 or later.
Is CVE-2020-15157 being exploited?
There is no known exploitation of CVE-2020-15157 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as DEBIAN-CVE-2020-15157, GHSA-742w-89gc-8m9c, GO-2022-0803, MGASA-2020-0406, UBUNTU-CVE-2020-15157, USN-4589-1 and 1 more.