# CVE-2020-15157: containerd can be coerced into leaking credentials during image pull

> Attackers can steal registry or cloud credentials by tricking users into pulling malicious container images with foreign layer URLs.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Oct 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-15157, GHSA-742w-89gc-8m9c, GO-2022-0803, MGASA-2020-0406, UBUNTU-CVE-2020-15157, USN-4589-1, USN-4589-2

## What is CVE-2020-15157?

CVE-2020-15157 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 16 Oct 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In containerd (an industry-standard container runtime) before version 1.2.14 there is a credential leaking vulnerability. If a container image manifest in the OCI Image format or Docker Image V2 Schema 2 format includes a URL for the location of a specific image layer (otherwise known as a “foreign layer”), the default containerd resolver will follow that URL to attempt to download it. In v1.2.x but not 1.3.0 or later, the default containerd resolver will provide its authentication credentials if the server where the URL is located presents an HTTP 401 status code along with registry-specific HTTP headers. If an attacker publishes a public image with a manifest that directs one of the layers to be fetched from a web server they control and they trick a user or system into pulling the image, they can obtain the credentials used for pulling that image. In some cases, this may be the user's username and password for the registry. In other cases, this may be the credentials attached to the cloud virtual instance which can grant access to other cloud resources in the account. The default containerd resolver is used by the cri-containerd plugin (which can be used by Kubernetes), the ctr development tool, and other client programs that have explicitly linked against it. This vulnerability has been fixed in containerd 1.2.14. containerd 1.3 and later are not affected. If you are using containerd 1.3 or later, you are not affected. If you are using cri-containerd in the 1.2 series or prior, you should ensure you only pull images from trusted sources. Other container runtimes built on top of containerd but not using the default resolver (such as Docker) are not affected.

Weakness: CWE-522 (Insufficiently Protected Credentials)

## Which versions are affected by CVE-2020-15157?

3 open source packages ship an affected version, including github.com/containerd/containerd. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/containerd/containerd` | Go | All versions | 1.2.14 |
| `github.com/containerd/containerd` | Go | All versions | 1.2.14 |
| `github.com/containerd/containerd` | Go | All versions | 1.2.14 |

Products: Canonical Ubuntu Linux, Debian Debian Linux, Linuxfoundation Containerd.

## How do I fix CVE-2020-15157?

Upgrade github.com/containerd/containerd to 1.2.14 or later.

## Is CVE-2020-15157 being exploited?

There is no known exploitation of CVE-2020-15157 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15157 and fix it if it is affected.

What it is: CVE-2020-15157 is a medium-severity vulnerability in Canonical Ubuntu Linux, published on 16 Oct 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-15157 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/containerd/containerd (Go): affected all versions; fixed in 1.2.14
- github.com/containerd/containerd (Go): affected all versions; fixed in 1.2.14
- github.com/containerd/containerd (Go): affected all versions; fixed in 1.2.14

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15157/ (Markdown: https://insights.sbomify.com/CVE-2020-15157/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15157
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15157
- OSV: https://osv.dev/vulnerability/CVE-2020-15157

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15157/
Summaries are generated and may contain mistakes; the official description above is the record.
