CVE-2020-15158 Heap buffer overflow in libIEC61850

High 7.7 Published Updated

An integer underflow in libIEC61850 allows remote attackers to cause a heap buffer overflow, leading to application crashes or remote code execution.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2020-15158?

CVE-2020-15158 is a high-severity vulnerability in mz-automation libiec61850, published on 26 Aug 2020. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

In libIEC61850 before version 1.4.3, when a message with COTP message length field with value < 4 is received an integer underflow will happen leading to heap buffer overflow. This can cause an application crash or on some platforms even the execution of remote code. If your application is used in open networks or there are untrusted nodes in the network it is highly recommend to apply the patch. This was patched with commit 033ab5b. Users of version 1.4.x should upgrade to version 1.4.3 when available. As a workaround changes of commit 033ab5b can be applied to older versions.

Weakness: CWE-191, CWE-122, CWE-119

Which versions are affected by CVE-2020-15158?

It affects 1 product.

Products include Mz-Automation Libiec61850.

How do I fix CVE-2020-15158?

No fix has been published for CVE-2020-15158 yet. Limit exposure of the affected software until one is available.

Is CVE-2020-15158 being exploited?

There is no known exploitation of CVE-2020-15158 in the wild and no public exploit code.

Sources

Also known as GHSA-pq77-fmf7-hjw8.

Is CVE-2020-15158 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free