{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-15158 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2020-15158 yet. Limit exposure of the affected software until one is available.","what":"CVE-2020-15158 is a high-severity vulnerability in mz-automation libiec61850, published on 26 Aug 2020. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-15158 and fix it if it is affected.\n\nWhat it is: CVE-2020-15158 is a high-severity vulnerability in mz-automation libiec61850, published on 26 Aug 2020. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-15158 in the wild and no public exploit code.\n\nAffected product: mz-automation libiec61850. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-15158/ (Markdown: https://insights.sbomify.com/CVE-2020-15158/index.md)","id":"CVE-2020-15158","markdown":"https://insights.sbomify.com/CVE-2020-15158/index.md","name":"CVE-2020-15158","record":{"aliases":["GHSA-pq77-fmf7-hjw8"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"IEC 61850 library","requires_auth":"low_privilege","summary":"An integer underflow in libIEC61850 allows remote attackers to cause a heap buffer overflow, leading to application crashes or remote code execution.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"libiec61850","vendor":"mz-automation"}],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:L/I:L/A:H","version":"3.1"},"cwes":[{"id":"CWE-191","name":"Integer Underflow (Wrap or Wraparound)"},{"id":"CWE-122","name":"Heap-based Buffer Overflow"},{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"In libIEC61850 before version 1.4.3, when a message with COTP message length field with value \u003c 4 is received an integer underflow will happen leading to heap buffer overflow. This can cause an application crash or on some platforms even the execution of remote code. If your application is used in open networks or there are untrusted nodes in the network it is highly recommend to apply the patch. This was patched with commit 033ab5b. Users of version 1.4.x should upgrade to version 1.4.3 when available. As a workaround changes of commit 033ab5b can be applied to older versions.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Heap buffer overflow in libIEC61850","id":"CVE-2020-15158","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"integer_overflow","year":"2020"},"n_packages":0,"n_references":3,"next":{"headline":"Cross Site Scripting leading to RCE in baserCMS","id":"CVE-2020-15159"},"packages":[],"prev":{"headline":"containerd can be coerced into leaking credentials during image pull","id":"CVE-2020-15157"},"products":["libiec61850"],"published":"2020-08-26","related":[{"cvss_score":10,"headline":"MZ Automation libIEC61850 Stack-Based Buffer Overflow","id":"CVE-2022-2970","kev_date_added":null,"published":"2022-09-23"},{"cvss_score":10,"headline":"MZ Automation libIEC61850 Stack-Based Buffer Overflow","id":"CVE-2022-2972","kev_date_added":null,"published":"2022-09-23"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2024-45970","kev_date_added":null,"published":"2024-11-15"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2024-45971","kev_date_added":null,"published":"2024-11-15"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2018-19185","kev_date_added":null,"published":"2018-11-12"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2018-18957","kev_date_added":null,"published":"2018-11-05"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2018-18834","kev_date_added":null,"published":"2018-10-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["mz-automation"]},"summary":"An integer underflow in libIEC61850 allows remote attackers to cause a heap buffer overflow, leading to application crashes or remote code execution.","url":"https://insights.sbomify.com/CVE-2020-15158/"}