CVE-2020-15159 Cross Site Scripting leading to RCE in baserCMS

High 7.6 Published Updated

An authenticated administrator can upload malicious scripts via XSS to achieve remote code execution in baserCMS.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2020-15159?

CVE-2020-15159 is a high-severity cross-site scripting vulnerability in Basercms Basercms, published on 28 Aug 2020. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

Official description

baserCMS 4.3.6 and earlier is affected by Cross Site Scripting (XSS) and Remote Code Execution (RCE). This may be executed by logging in as a system administrator and uploading an executable script file such as a PHP file.The affected components are ThemeFilesController.php and UploaderFilesController.php. This is fixed in version 4.3.7.

Weakness: CWE-79

Which versions are affected by CVE-2020-15159?

2 open source packages ship an affected version, including baserproject/basercms. It affects 1 product.

PackageAffectedFixed in
baserproject/basercms PackagistFrom 4.0.04.3.7
baserproject/basercms PackagistFrom 4.0.04.3.7

Products include Basercms Basercms.

How do I fix CVE-2020-15159?

Upgrade baserproject/basercms to 4.3.7 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2020-15159 being exploited?

There is no known exploitation of CVE-2020-15159 in the wild and no public exploit code.

All Basercms Basercms vulnerabilities

Sources

Also known as GHSA-673x-f5wx-fxpw.

Is CVE-2020-15159 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free