CVE-2020-15161 Potential XSS in PrestaShop

Medium 5.4 Published Updated

Attackers can inject JavaScript via the contact form in PrestaShop, potentially leading to session hijacking or malicious actions.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2020-15161?

CVE-2020-15161 is a medium-severity cross-site scripting vulnerability in Prestashop Prestashop, published on 24 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

In PrestaShop from version 1.6.0.4 and before version 1.7.6.8 an attacker is able to inject javascript while using the contact form. The problem is fixed in 1.7.6.8

Weakness: CWE-79

Which versions are affected by CVE-2020-15161?

It affects 1 product.

Products include Prestashop Prestashop.

How do I fix CVE-2020-15161?

No fix has been published for CVE-2020-15161 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2020-15161 being exploited?

There is no known exploitation of CVE-2020-15161 in the wild and no public exploit code.

All Prestashop Prestashop vulnerabilities

Sources

Also known as GHSA-5cp2-r794-w37w.

Is CVE-2020-15161 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free