# CVE-2020-15162: Stored XSS in PrestaShop

> Attackers can inject malicious JavaScript via file attachments, leading to stored XSS attacks against PrestaShop users.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 24 Sep 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-rc8c-v7rq-q392

## What is CVE-2020-15162?

CVE-2020-15162 is a medium-severity cross-site scripting vulnerability in Prestashop Prestashop, published on 24 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In PrestaShop from version 1.5.0.0 and before version 1.7.6.8, users are allowed to send compromised files. These attachments allowed people to input malicious JavaScript which triggered an XSS payload. The problem is fixed in version 1.7.6.8.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-15162?

It affects 1 product.


Products: Prestashop Prestashop.

## How do I fix CVE-2020-15162?

No fix has been published for CVE-2020-15162 yet. Limit exposure of the affected software until one is available.

## Is CVE-2020-15162 being exploited?

There is no known exploitation of CVE-2020-15162 in the wild and no public exploit code.

## Other vulnerabilities in Prestashop Prestashop

- [CVE-2023-30839](https://insights.sbomify.com/CVE-2023-30839/): PrestaShop vulnerable to SQL filter bypass leading to arbitrary write requests using "SQL Manager" (critical 10.0)
- [CVE-2008-5791](https://insights.sbomify.com/CVE-2008-5791/): Other in n/a (critical 10.0)
- [CVE-2024-41651](https://insights.sbomify.com/CVE-2024-41651/): Server-side request forgery in n/a (critical 9.8)
- [CVE-2022-31181](https://insights.sbomify.com/CVE-2022-31181/): Remote code execution in prestashop (critical 9.8)
- [CVE-2021-3110](https://insights.sbomify.com/CVE-2021-3110/): SQL injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15162 and fix it if it is affected.

What it is: CVE-2020-15162 is a medium-severity cross-site scripting vulnerability in Prestashop Prestashop, published on 24 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-15162 in the wild and no public exploit code.

Affected product: Prestashop Prestashop. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15162/ (Markdown: https://insights.sbomify.com/CVE-2020-15162/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15162
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15162
- OSV: https://osv.dev/vulnerability/CVE-2020-15162

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15162/
Summaries are generated and may contain mistakes; the official description above is the record.
