CVE-2020-15163 Invalid root may become trusted root in The Update Framework (TUF)

High 8.7 Published Updated

Attackers can compromise the software update trust chain by serving invalid root metadata, enabling malicious code execution via future updates.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2020-15163?

CVE-2020-15163 is a high-severity vulnerability in theupdateframework tuf, published on 9 Sep 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

Python TUF (The Update Framework) reference implementation before version 0.12 it will incorrectly trust a previously downloaded root metadata file which failed verification at download time. This allows an attacker who is able to serve multiple new versions of root metadata (i.e. by a person-in-the-middle attack) culminating in a version which has not been correctly signed to control the trust chain for future updates. This is fixed in version 0.12 and newer.

Weakness: CWE-345, CWE-863

Which versions are affected by CVE-2020-15163?

3 open source packages ship an affected version, including tuf. It affects 1 product.

PackageAffectedFixed in
tuf PyPIAll versions0.12.0
tuf PyPIAll versions0.12.0
tuf PyPIAll versions0.12.0

Products include Linuxfoundation the Update Framework.

How do I fix CVE-2020-15163?

Upgrade tuf to 0.12.0 or later.

Is CVE-2020-15163 being exploited?

There is no known exploitation of CVE-2020-15163 in the wild and no public exploit code.

Sources

Also known as GHSA-f8mr-jv2c-v8mg, PYSEC-2020-145.

Is CVE-2020-15163 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free