{"answers":{"affected":"3 open source packages ship an affected version, including tuf. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-15163 in the wild and no public exploit code.","fix":"Upgrade tuf to 0.12.0 or later.","what":"CVE-2020-15163 is a high-severity vulnerability in theupdateframework tuf, published on 9 Sep 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-15163 and fix it if it is affected.\n\nWhat it is: CVE-2020-15163 is a high-severity vulnerability in theupdateframework tuf, published on 9 Sep 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-15163 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- tuf (PyPI): affected all versions; fixed in 0.12.0\n- tuf (PyPI): affected all versions; fixed in 0.12.0\n- tuf (PyPI): affected all versions; fixed in 0.12.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-15163/ (Markdown: https://insights.sbomify.com/CVE-2020-15163/index.md)","id":"CVE-2020-15163","markdown":"https://insights.sbomify.com/CVE-2020-15163/index.md","name":"CVE-2020-15163","record":{"aliases":["GHSA-f8mr-jv2c-v8mg","PYSEC-2020-145"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Python TUF library","requires_auth":"low_privilege","summary":"Attackers can compromise the software update trust chain by serving invalid root metadata, enabling malicious code execution via future updates.","user_interaction":"required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"the_update_framework","vendor":"linuxfoundation"}],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-345","name":"Insufficient Verification of Data Authenticity"},{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"Python TUF (The Update Framework) reference implementation before version 0.12 it will incorrectly trust a previously downloaded root metadata file which failed verification at download time. This allows an attacker who is able to serve multiple new versions of root metadata (i.e. by a person-in-the-middle attack) culminating in a version which has not been correctly signed to control the trust chain for future updates. This is fixed in version 0.12 and newer.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Invalid root may become trusted root in The Update Framework (TUF)","id":"CVE-2020-15163","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"supply_chain","year":"2020"},"n_packages":3,"n_references":5,"next":{"headline":"Authentication Bypass in Scratch Login (mediawiki-scratch-login)","id":"CVE-2020-15164"},"packages":[{"ecosystem":"PyPI","fixed":["0.12.0"],"introduced":["0"],"last_affected":[],"package":"tuf","purl":null,"source":"GHSA-f8mr-jv2c-v8mg"},{"ecosystem":"PyPI","fixed":["0.12.0"],"introduced":["0"],"last_affected":[],"package":"tuf","purl":"pkg:pypi/tuf","source":"GHSA-f8mr-jv2c-v8mg"},{"ecosystem":"PyPI","fixed":["0.12.0"],"introduced":["0"],"last_affected":[],"package":"tuf","purl":"pkg:pypi/tuf","source":"PYSEC-2020-145"}],"prev":{"headline":"Stored XSS in PrestaShop","id":"CVE-2020-15162"},"products":["tuf"],"published":"2020-09-09","related":[{"cvss_score":9.8,"headline":"Incorrect threshold signature computation in TUF","id":"CVE-2020-6174","kev_date_added":null,"published":"2020-02-05"},{"cvss_score":7.5,"headline":"Client metadata path-traversal in python-tuf","id":"CVE-2021-41131","kev_date_added":null,"published":"2021-10-19"},{"cvss_score":5.3,"headline":"Client Denial of Service on TUF","id":"CVE-2020-6173","kev_date_added":null,"published":"2020-01-14"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["theupdateframework"]},"summary":"Attackers can compromise the software update trust chain by serving invalid root metadata, enabling malicious code execution via future updates.","url":"https://insights.sbomify.com/CVE-2020-15163/"}