# CVE-2020-15163: Invalid root may become trusted root in The Update Framework (TUF)

> Attackers can compromise the software update trust chain by serving invalid root metadata, enabling malicious code execution via future updates.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 9 Sep 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-f8mr-jv2c-v8mg, PYSEC-2020-145

## What is CVE-2020-15163?

CVE-2020-15163 is a high-severity vulnerability in theupdateframework tuf, published on 9 Sep 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Python TUF (The Update Framework) reference implementation before version 0.12 it will incorrectly trust a previously downloaded root metadata file which failed verification at download time. This allows an attacker who is able to serve multiple new versions of root metadata (i.e. by a person-in-the-middle attack) culminating in a version which has not been correctly signed to control the trust chain for future updates. This is fixed in version 0.12 and newer.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity), CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2020-15163?

3 open source packages ship an affected version, including tuf. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tuf` | PyPI | All versions | 0.12.0 |
| `tuf` | PyPI | All versions | 0.12.0 |
| `tuf` | PyPI | All versions | 0.12.0 |

Products: Linuxfoundation the Update Framework.

## How do I fix CVE-2020-15163?

Upgrade tuf to 0.12.0 or later.

## Is CVE-2020-15163 being exploited?

There is no known exploitation of CVE-2020-15163 in the wild and no public exploit code.

## Other vulnerabilities in theupdateframework tuf

- [CVE-2020-6174](https://insights.sbomify.com/CVE-2020-6174/): Incorrect threshold signature computation in TUF (critical 9.8)
- [CVE-2021-41131](https://insights.sbomify.com/CVE-2021-41131/): Client metadata path-traversal in python-tuf (high 7.5)
- [CVE-2020-6173](https://insights.sbomify.com/CVE-2020-6173/): Client Denial of Service on TUF (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15163 and fix it if it is affected.

What it is: CVE-2020-15163 is a high-severity vulnerability in theupdateframework tuf, published on 9 Sep 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-15163 in the wild and no public exploit code.

Affected packages and fixed versions:
- tuf (PyPI): affected all versions; fixed in 0.12.0
- tuf (PyPI): affected all versions; fixed in 0.12.0
- tuf (PyPI): affected all versions; fixed in 0.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15163/ (Markdown: https://insights.sbomify.com/CVE-2020-15163/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15163
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15163
- OSV: https://osv.dev/vulnerability/CVE-2020-15163

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15163/
Summaries are generated and may contain mistakes; the official description above is the record.
