CVE-2020-15166 Denial of Service in ZeroMQ
Attackers can cause a denial of service in ZeroMQ by preventing legitimate clients from exchanging messages via TCP endpoints.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-15166?
CVE-2020-15166 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 11 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In ZeroMQ before version 4.3.3, there is a denial-of-service vulnerability. Users with TCP transport public endpoints, even with CURVE/ZAP enabled, are impacted. If a raw TCP socket is opened and connected to an endpoint that is fully configured with CURVE/ZAP, legitimate clients will not be able to exchange any message. Handshakes complete successfully, and messages are delivered to the library, but the server application never receives them. This is patched in version 4.3.3.
Weakness: CWE-400
Which versions are affected by CVE-2020-15166?
It affects 3 products.
Linux distribution packages (18)
libunwind SUSE:Linux Enterprise High Performance Computing 15-ESPOS | All versions | 1.2.1-4.2.3 |
zeromq SUSE:Linux Enterprise High Performance Computing 15-ESPOS | All versions | 4.2.3-3.15.4 |
libunwind SUSE:Linux Enterprise High Performance Computing 15-LTSS | All versions | 1.2.1-4.2.3 |
zeromq SUSE:Linux Enterprise High Performance Computing 15-LTSS | All versions | 4.2.3-3.15.4 |
libunwind SUSE:Linux Enterprise Module for Basesystem 15 SP1 | All versions | 1.2.1-4.2.3 |
zeromq SUSE:Linux Enterprise Module for Basesystem 15 SP1 | All versions | 4.2.3-3.15.4 |
libunwind SUSE:Linux Enterprise Module for Basesystem 15 SP2 | All versions | 1.2.1-4.2.3 |
zeromq SUSE:Linux Enterprise Module for Basesystem 15 SP2 | All versions | 4.2.3-3.15.4 |
libunwind SUSE:Linux Enterprise Module for Package Hub 15 SP1 | All versions | 1.2.1-4.2.3 |
libunwind SUSE:Linux Enterprise Module for Package Hub 15 SP2 | All versions | 1.2.1-4.2.3 |
libunwind SUSE:Linux Enterprise Server 15-LTSS | All versions | 1.2.1-4.2.3 |
zeromq SUSE:Linux Enterprise Server 15-LTSS | All versions | 4.2.3-3.15.4 |
libunwind SUSE:Linux Enterprise Server for SAP Applications 15 | All versions | 1.2.1-4.2.3 |
zeromq SUSE:Linux Enterprise Server for SAP Applications 15 | All versions | 4.2.3-3.15.4 |
libunwind openSUSE:Leap 15.1 | All versions | 1.2.1-lp151.4.3.1 |
zeromq openSUSE:Leap 15.1 | All versions | 4.2.3-lp151.5.6.1 |
libunwind openSUSE:Leap 15.2 | All versions | 1.2.1-lp152.5.3.1 |
zeromq openSUSE:Leap 15.2 | All versions | 4.2.3-lp152.7.3.1 |
Products include Debian Debian Linux, Fedoraproject Fedora, Zeromq Libzmq.
How do I fix CVE-2020-15166?
Upgrade to a fixed version.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2020-15166 being exploited?
There is no known exploitation of CVE-2020-15166 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as ALPINE-CVE-2020-15166, DEBIAN-CVE-2020-15166, DLA-2443-1, DSA-4761-1, GHSA-25wp-cf8g-938m, JLSEC-2026-513 and 6 more.