# CVE-2020-15166: Denial of Service in ZeroMQ

> Attackers can cause a denial of service in ZeroMQ by preventing legitimate clients from exchanging messages via TCP endpoints.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Sep 2020
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2020-15166, DEBIAN-CVE-2020-15166, DLA-2443-1, DSA-4761-1, GHSA-25wp-cf8g-938m, JLSEC-2026-513, MGASA-2020-0367, OESA-2024-1133, SUSE-SU-2020:3264-1, UBUNTU-CVE-2020-15166, openSUSE-SU-2020:1907-1, openSUSE-SU-2020:1910-1

## What is CVE-2020-15166?

CVE-2020-15166 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 11 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In ZeroMQ before version 4.3.3, there is a denial-of-service vulnerability. Users with TCP transport public endpoints, even with CURVE/ZAP enabled, are impacted. If a raw TCP socket is opened and connected to an endpoint that is fully configured with CURVE/ZAP, legitimate clients will not be able to exchange any message. Handshakes complete successfully, and messages are delivered to the library, but the server application never receives them. This is patched in version 4.3.3.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2020-15166?

It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `libunwind` | SUSE:Linux Enterprise High Performance Computing 15-ESPOS | All versions | 1.2.1-4.2.3 |
| `zeromq` | SUSE:Linux Enterprise High Performance Computing 15-ESPOS | All versions | 4.2.3-3.15.4 |
| `libunwind` | SUSE:Linux Enterprise High Performance Computing 15-LTSS | All versions | 1.2.1-4.2.3 |
| `zeromq` | SUSE:Linux Enterprise High Performance Computing 15-LTSS | All versions | 4.2.3-3.15.4 |
| `libunwind` | SUSE:Linux Enterprise Module for Basesystem 15 SP1 | All versions | 1.2.1-4.2.3 |
| `zeromq` | SUSE:Linux Enterprise Module for Basesystem 15 SP1 | All versions | 4.2.3-3.15.4 |
| `libunwind` | SUSE:Linux Enterprise Module for Basesystem 15 SP2 | All versions | 1.2.1-4.2.3 |
| `zeromq` | SUSE:Linux Enterprise Module for Basesystem 15 SP2 | All versions | 4.2.3-3.15.4 |
| `libunwind` | SUSE:Linux Enterprise Module for Package Hub 15 SP1 | All versions | 1.2.1-4.2.3 |
| `libunwind` | SUSE:Linux Enterprise Module for Package Hub 15 SP2 | All versions | 1.2.1-4.2.3 |
| `libunwind` | SUSE:Linux Enterprise Server 15-LTSS | All versions | 1.2.1-4.2.3 |
| `zeromq` | SUSE:Linux Enterprise Server 15-LTSS | All versions | 4.2.3-3.15.4 |
| `libunwind` | SUSE:Linux Enterprise Server for SAP Applications 15 | All versions | 1.2.1-4.2.3 |
| `zeromq` | SUSE:Linux Enterprise Server for SAP Applications 15 | All versions | 4.2.3-3.15.4 |
| `libunwind` | openSUSE:Leap 15.1 | All versions | 1.2.1-lp151.4.3.1 |
| `zeromq` | openSUSE:Leap 15.1 | All versions | 4.2.3-lp151.5.6.1 |
| `libunwind` | openSUSE:Leap 15.2 | All versions | 1.2.1-lp152.5.3.1 |
| `zeromq` | openSUSE:Leap 15.2 | All versions | 4.2.3-lp152.7.3.1 |

Products: Debian Debian Linux, Fedoraproject Fedora, Zeromq Libzmq.

## How do I fix CVE-2020-15166?

Upgrade to a fixed version.

## Is CVE-2020-15166 being exploited?

There is no known exploitation of CVE-2020-15166 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15166 and fix it if it is affected.

What it is: CVE-2020-15166 is a high-severity denial of service vulnerability in Debian Debian Linux, published on 11 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-15166 in the wild and no public exploit code.

Affected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15166/ (Markdown: https://insights.sbomify.com/CVE-2020-15166/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15166
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15166
- OSV: https://osv.dev/vulnerability/CVE-2020-15166

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15166/
Summaries are generated and may contain mistakes; the official description above is the record.
