CVE-2020-15169 XSS in Action View
Attackers can execute arbitrary scripts via XSS in Action View translation helpers when user-controlled defaults are used for HTML keys.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-15169?
CVE-2020-15169 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 11 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In Action View before versions 5.2.4.4 and 6.0.3.3 there is a potential Cross-Site Scripting (XSS) vulnerability in Action View's translation helpers. Views that allow the user to control the default (not found) value of the `t` and `translate` helpers could be susceptible to XSS attacks. When an HTML-unsafe string is passed as the default for a missing translation key named html or ending in _html, the default string is incorrectly marked as HTML-safe and not escaped. This is patched in versions 6.0.3.3 and 5.2.4.4. A workaround without upgrading is proposed in the source advisory.
Weakness: CWE-79
Which versions are affected by CVE-2020-15169?
4 open source packages ship an affected version, including actionview. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
actionview RubyGems | All versions | 5.2.4.4 |
actionview RubyGems | All versions | 5.2.4.4 |
actionview RubyGems | From 6.0.0.0 | 6.0.3.3 |
actionview RubyGems | From 6.0.0.0 | 6.0.3.3 |
Linux distribution packages (4)
rubygem-actionview-4_2 SUSE:OpenStack Cloud 6-LTSS | All versions | 4.2.9-9.12.1 |
rubygem-actionview-4_2 SUSE:OpenStack Cloud 7 | All versions | 4.2.9-9.12.1 |
rubygem-actionview-4_2 SUSE:OpenStack Cloud Crowbar 8 | All versions | 4.2.9-9.12.1 |
rubygem-actionview-4_2 SUSE:OpenStack Cloud Crowbar 9 | All versions | 4.2.9-9.12.1 |
Products include Action View Project Action View, Debian Debian Linux, Fedoraproject Fedora.
How do I fix CVE-2020-15169?
Upgrade actionview to a fixed version for your release line: 5.2.4.4 or 6.0.3.3.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2020-15169 being exploited?
There is no known exploitation of CVE-2020-15169 in the wild and no public exploit code.
Public exploit code: 1 proofs of concept on GitHub.
Sources
Also known as DEBIAN-CVE-2020-15169, DLA-2403-1, GHSA-cfjv-5498-mph5, OESA-2021-1180, SUSE-SU-2020:2686-1, UBUNTU-CVE-2020-15169.