{"answers":{"affected":"4 open source packages ship an affected version, including actionview. It affects 3 products.","exploited":"There is no known exploitation of CVE-2020-15169 in the wild and no public exploit code.","fix":"Upgrade actionview to a fixed version for your release line: 5.2.4.4 or 6.0.3.3.","what":"CVE-2020-15169 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 11 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2020-15169 and fix it if it is affected.\n\nWhat it is: CVE-2020-15169 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 11 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2020-15169 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- actionview (RubyGems): affected all versions; fixed in 5.2.4.4\n- actionview (RubyGems): affected all versions; fixed in 5.2.4.4\n- actionview (RubyGems): affected from 6.0.0.0; fixed in 6.0.3.3\n- actionview (RubyGems): affected from 6.0.0.0; fixed in 6.0.3.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-15169/ (Markdown: https://insights.sbomify.com/CVE-2020-15169/index.md)","id":"CVE-2020-15169","markdown":"https://insights.sbomify.com/CVE-2020-15169/index.md","name":"CVE-2020-15169","record":{"aliases":["DEBIAN-CVE-2020-15169","DLA-2403-1","GHSA-cfjv-5498-mph5","OESA-2021-1180","SUSE-SU-2020:2686-1","UBUNTU-CVE-2020-15169"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby on Rails","requires_auth":"none","summary":"Attackers can execute arbitrary scripts via XSS in Action View translation helpers when user-controlled defaults are used for HTML keys.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"action_view","vendor":"action_view_project"},{"product":"debian_linux","vendor":"debian"},{"product":"fedora","vendor":"fedoraproject"}],"cvss":{"score":5.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"In Action View before versions 5.2.4.4 and 6.0.3.3 there is a potential Cross-Site Scripting (XSS) vulnerability in Action View's translation helpers. Views that allow the user to control the default (not found) value of the `t` and `translate` helpers could be susceptible to XSS attacks. When an HTML-unsafe string is passed as the default for a missing translation key named html or ending in _html, the default string is incorrectly marked as HTML-safe and not escaped. This is patched in versions 6.0.3.3 and 5.2.4.4. A workaround without upgrading is proposed in the source advisory.","ecosystems":["RubyGems","SUSE:OpenStack Cloud 6-LTSS","SUSE:OpenStack Cloud 7","SUSE:OpenStack Cloud Crowbar 8","SUSE:OpenStack Cloud Crowbar 9"],"exploits":{"exploitdb":0,"first_seen":"2020-10-08","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2020-10-08T15:42:37Z","kind":"github_poc","ref":"https://github.com/glasses618/CVE-2020-15169","stars":0,"title":null}],"tier":"poc_unverified"},"has_fix":true,"headline":"XSS in Action View","id":"CVE-2020-15169","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"debian:debian_linux","products":["debian:debian_linux","fedoraproject:fedora"],"type":"xss","year":"2020"},"n_packages":8,"n_references":4,"next":{"headline":"Missing access control in apollo-adminservice","id":"CVE-2020-15170"},"packages":[{"ecosystem":"RubyGems","fixed":["5.2.4.4"],"introduced":["0"],"last_affected":[],"package":"actionview","purl":null,"source":"GHSA-cfjv-5498-mph5"},{"ecosystem":"RubyGems","fixed":["5.2.4.4"],"introduced":["0"],"last_affected":[],"package":"actionview","purl":"pkg:gem/actionview","source":"GHSA-cfjv-5498-mph5"},{"ecosystem":"RubyGems","fixed":["6.0.3.3"],"introduced":["6.0.0.0"],"last_affected":[],"package":"actionview","purl":null,"source":"GHSA-cfjv-5498-mph5"},{"ecosystem":"RubyGems","fixed":["6.0.3.3"],"introduced":["6.0.0.0"],"last_affected":[],"package":"actionview","purl":"pkg:gem/actionview","source":"GHSA-cfjv-5498-mph5"},{"ecosystem":"SUSE:OpenStack Cloud 6-LTSS","fixed":["4.2.9-9.12.1"],"introduced":["0"],"last_affected":[],"package":"rubygem-actionview-4_2","purl":"pkg:rpm/suse/rubygem-actionview-4_2\u0026distro=SUSE%20OpenStack%20Cloud%206-LTSS","source":"SUSE-SU-2020:2686-1"},{"ecosystem":"SUSE:OpenStack Cloud 7","fixed":["4.2.9-9.12.1"],"introduced":["0"],"last_affected":[],"package":"rubygem-actionview-4_2","purl":"pkg:rpm/suse/rubygem-actionview-4_2\u0026distro=SUSE%20OpenStack%20Cloud%207","source":"SUSE-SU-2020:2686-1"},{"ecosystem":"SUSE:OpenStack Cloud Crowbar 8","fixed":["4.2.9-9.12.1"],"introduced":["0"],"last_affected":[],"package":"rubygem-actionview-4_2","purl":"pkg:rpm/suse/rubygem-actionview-4_2\u0026distro=SUSE%20OpenStack%20Cloud%20Crowbar%208","source":"SUSE-SU-2020:2686-1"},{"ecosystem":"SUSE:OpenStack Cloud Crowbar 9","fixed":["4.2.9-9.12.1"],"introduced":["0"],"last_affected":[],"package":"rubygem-actionview-4_2","purl":"pkg:rpm/suse/rubygem-actionview-4_2\u0026distro=SUSE%20OpenStack%20Cloud%20Crowbar%209","source":"SUSE-SU-2020:2686-1"}],"prev":{"headline":"File size limit bypass in node-fetch","id":"CVE-2020-15168"},"products":["actionview"],"published":"2020-09-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-04","vendors":["rails"]},"summary":"Attackers can execute arbitrary scripts via XSS in Action View translation helpers when user-controlled defaults are used for HTML keys.","url":"https://insights.sbomify.com/CVE-2020-15169/"}