# CVE-2020-15169: XSS in Action View

> Attackers can execute arbitrary scripts via XSS in Action View translation helpers when user-controlled defaults are used for HTML keys.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Sep 2020
- **Updated:** 4 Aug 2024
- **Also known as:** DEBIAN-CVE-2020-15169, DLA-2403-1, GHSA-cfjv-5498-mph5, OESA-2021-1180, SUSE-SU-2020:2686-1, UBUNTU-CVE-2020-15169

## What is CVE-2020-15169?

CVE-2020-15169 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 11 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Action View before versions 5.2.4.4 and 6.0.3.3 there is a potential Cross-Site Scripting (XSS) vulnerability in Action View's translation helpers. Views that allow the user to control the default (not found) value of the `t` and `translate` helpers could be susceptible to XSS attacks. When an HTML-unsafe string is passed as the default for a missing translation key named html or ending in _html, the default string is incorrectly marked as HTML-safe and not escaped. This is patched in versions 6.0.3.3 and 5.2.4.4. A workaround without upgrading is proposed in the source advisory.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2020-15169?

4 open source packages ship an affected version, including actionview. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `actionview` | RubyGems | All versions | 5.2.4.4 |
| `actionview` | RubyGems | All versions | 5.2.4.4 |
| `actionview` | RubyGems | From 6.0.0.0 | 6.0.3.3 |
| `actionview` | RubyGems | From 6.0.0.0 | 6.0.3.3 |
| `rubygem-actionview-4_2` | SUSE:OpenStack Cloud 6-LTSS | All versions | 4.2.9-9.12.1 |
| `rubygem-actionview-4_2` | SUSE:OpenStack Cloud 7 | All versions | 4.2.9-9.12.1 |
| `rubygem-actionview-4_2` | SUSE:OpenStack Cloud Crowbar 8 | All versions | 4.2.9-9.12.1 |
| `rubygem-actionview-4_2` | SUSE:OpenStack Cloud Crowbar 9 | All versions | 4.2.9-9.12.1 |

Products: Action View Project Action View, Debian Debian Linux, Fedoraproject Fedora.

## How do I fix CVE-2020-15169?

Upgrade actionview to a fixed version for your release line: 5.2.4.4 or 6.0.3.3.

## Is CVE-2020-15169 being exploited?

There is no known exploitation of CVE-2020-15169 in the wild and no public exploit code.

Public exploit code:

- https://github.com/glasses618/CVE-2020-15169 (github_poc): https://github.com/glasses618/CVE-2020-15169

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15169 and fix it if it is affected.

What it is: CVE-2020-15169 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 11 Sep 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-15169 in the wild and no public exploit code.

Affected packages and fixed versions:
- actionview (RubyGems): affected all versions; fixed in 5.2.4.4
- actionview (RubyGems): affected all versions; fixed in 5.2.4.4
- actionview (RubyGems): affected from 6.0.0.0; fixed in 6.0.3.3
- actionview (RubyGems): affected from 6.0.0.0; fixed in 6.0.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15169/ (Markdown: https://insights.sbomify.com/CVE-2020-15169/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15169
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15169
- OSV: https://osv.dev/vulnerability/CVE-2020-15169

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15169/
Summaries are generated and may contain mistakes; the official description above is the record.
