CVE-2020-15171 Users with SCRIPT rights can execute arbitrary code in XWiki
Users with SCRIPT rights can execute arbitrary code by accessing the Servlet context, requiring upgrades or restricting rights to trusted users.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-15171?
CVE-2020-15171 is a medium-severity code injection vulnerability in Xwiki Xwiki, published on 10 Sep 2020. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
In XWiki before versions 11.10.5 or 12.2.1, any user with SCRIPT right (EDIT right before XWiki 7.4) can gain access to the application server Servlet context which contains tools allowing to instantiate arbitrary Java objects and invoke methods that may lead to arbitrary code execution. The only workaround is to give SCRIPT right only to trusted users.
Which versions are affected by CVE-2020-15171?
4 open source packages ship an affected version, including org.xwiki.platform:xwiki-platform-oldcore. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
org.xwiki.platform:xwiki-platform-oldcore Maven | All versions | 11.10.5 |
org.xwiki.platform:xwiki-platform-oldcore Maven | All versions | 11.10.5 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 12.0.0 | 12.2.1 |
org.xwiki.platform:xwiki-platform-oldcore Maven | From 12.0.0 | 12.2.1 |
Products include Xwiki Xwiki.
How do I fix CVE-2020-15171?
Upgrade org.xwiki.platform:xwiki-platform-oldcore to a fixed version for your release line: 11.10.5 or 12.2.1.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2020-15171 being exploited?
There is no known exploitation of CVE-2020-15171 in the wild and no public exploit code.
Other vulnerabilities in Xwiki Xwiki
- CVE-2025-24893 XWiki Platform Eval Injection
- CVE-2025-53836 XWiki Rendering is vulnerable to RCE attacks when processing nested macros
- CVE-2024-55662 XWiki allows remote code execution through the extension sheet
- CVE-2024-55877 XWiki allows remote code execution from account through macro descriptions and XWiki.XWikiSyntaxMacrosList
- CVE-2024-37901 XWiki Platform vulnerable to remote code execution from account via SearchSuggestConfigSheet
Sources
Also known as GHSA-7qw5-pqhc-xm4g.