# CVE-2020-15174: Unpreventable top-level navigation in Electron

> Attackers can bypass navigation security controls in Electron apps via sub-frame top-level navigation, requiring an upgrade or iframe sandboxing.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:N/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-2q4g-w47c-4674

## What is CVE-2020-15174?

CVE-2020-15174 is a high-severity vulnerability in Electronjs Electron, published on 6 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Electron before versions 11.0.0-beta.1, 10.0.1, 9.3.0 or 8.5.1 the `will-navigate` event that apps use to prevent navigations to unexpected destinations as per our security recommendations can be bypassed when a sub-frame performs a top-frame navigation across sites. The issue is patched in versions 11.0.0-beta.1, 10.0.1, 9.3.0 or 8.5.1 As a workaround sandbox all your iframes using the sandbox attribute. This will prevent them creating top-frame navigations and is good practice anyway.

Weakness: CWE-693 (Protection Mechanism Failure), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2020-15174?

6 open source packages ship an affected version, including electron. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `electron` | npm | From 10.0.0-beta.0 | 10.0.1 |
| `electron` | npm | From 10.0.0-beta.0 | 10.0.1 |
| `electron` | npm | From 8.0.0-beta.0 | 8.5.1 |
| `electron` | npm | From 8.0.0-beta.0 | 8.5.1 |
| `electron` | npm | From 9.0.0-beta.0 | 9.3.0 |
| `electron` | npm | From 9.0.0-beta.0 | 9.3.0 |

Products: Electronjs Electron.

## How do I fix CVE-2020-15174?

Upgrade electron to a fixed version for your release line: 10.0.1, 8.5.1 or 9.3.0.

## Is CVE-2020-15174 being exploited?

There is no known exploitation of CVE-2020-15174 in the wild and no public exploit code.

## Other vulnerabilities in Electronjs Electron

- [CVE-2017-16151](https://insights.sbomify.com/CVE-2017-16151/): Chromium Remote Code Execution in electron (critical 9.8)
- [CVE-2018-1000118](https://insights.sbomify.com/CVE-2018-1000118/): Electron protocol handler browser vulnerable to Command Injection (high 8.8)
- [CVE-2026-34780](https://insights.sbomify.com/CVE-2026-34780/): Electron: Context Isolation bypass via contextBridge VideoFrame transfer (high 8.4)
- [CVE-2026-102676](https://insights.sbomify.com/CVE-2026-102676/): Electron: <webview> can enable Node.js integration in Web Workers despite embedder restrictions (high 8.3)
- [CVE-2026-102673](https://insights.sbomify.com/CVE-2026-102673/): Electron drops inherited HTML sandbox restrictions for popups opened through OpenURLFromTab (high 8.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15174 and fix it if it is affected.

What it is: CVE-2020-15174 is a high-severity vulnerability in Electronjs Electron, published on 6 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-15174 in the wild and no public exploit code.

Affected packages and fixed versions:
- electron (npm): affected from 10.0.0-beta.0; fixed in 10.0.1
- electron (npm): affected from 10.0.0-beta.0; fixed in 10.0.1
- electron (npm): affected from 8.0.0-beta.0; fixed in 8.5.1
- electron (npm): affected from 8.0.0-beta.0; fixed in 8.5.1
- electron (npm): affected from 9.0.0-beta.0; fixed in 9.3.0
- electron (npm): affected from 9.0.0-beta.0; fixed in 9.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15174/ (Markdown: https://insights.sbomify.com/CVE-2020-15174/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15174
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15174
- OSV: https://osv.dev/vulnerability/CVE-2020-15174

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15174/
Summaries are generated and may contain mistakes; the official description above is the record.
