# CVE-2020-15175: Unauthenticated File Deletion in GLPI

> An unauthenticated attacker can delete the .htaccess file to expose sensitive files, potentially stealing admin session tokens for full account takeover.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 7 Oct 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-rm52-jx9h-rwcp, UBUNTU-CVE-2020-15175

## What is CVE-2020-15175?

CVE-2020-15175 is a high-severity path traversal vulnerability in Glpi-Project Glpi, published on 7 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In GLPI before version 9.5.2, the `​pluginimage.send.php​` endpoint allows a user to specify an image from a plugin. The parameters can be maliciously crafted to instead delete the .htaccess file for the files directory. Any user becomes able to read all the files and folders contained in “/files/”. Some of the sensitive information that is compromised are the user sessions, logs, and more. An attacker would be able to get the Administrators session token and use that to authenticate. The issue is patched in version 9.5.2.

Weakness: CWE-552 (Files or Directories Accessible to External Parties)

## Which versions are affected by CVE-2020-15175?

It affects 1 product.


Products: Glpi-Project Glpi.

## How do I fix CVE-2020-15175?

No fix has been published for CVE-2020-15175 yet. Limit exposure of the affected software until one is available.

## Is CVE-2020-15175 being exploited?

There is no known exploitation of CVE-2020-15175 in the wild and no public exploit code.

Public exploit code:

- GLPI automatic exploitation tool for CVE-2020-15175 (github_poc): https://github.com/Xn2/GLPwn

## Other vulnerabilities in Glpi-Project Glpi

- [CVE-2022-35914](https://insights.sbomify.com/CVE-2022-35914/): Teclib GLPI Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2023-42802](https://insights.sbomify.com/CVE-2023-42802/): GLPI vulnerable to unallowed PHP script execution (critical 10.0)
- [CVE-2023-28849](https://insights.sbomify.com/CVE-2023-28849/): GLPI vulnerable to SQL injection and Stored XSS via inventory agent request (critical 10.0)
- [CVE-2022-35947](https://insights.sbomify.com/CVE-2022-35947/): SQL injection in GLPI (critical 10.0)
- [CVE-2022-31056](https://insights.sbomify.com/CVE-2022-31056/): SQL injection with _actor parameter in GLPI (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15175 and fix it if it is affected.

What it is: CVE-2020-15175 is a high-severity path traversal vulnerability in Glpi-Project Glpi, published on 7 Oct 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-15175 in the wild and no public exploit code.

Affected product: Glpi-Project Glpi. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15175/ (Markdown: https://insights.sbomify.com/CVE-2020-15175/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15175
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15175
- OSV: https://osv.dev/vulnerability/CVE-2020-15175

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15175/
Summaries are generated and may contain mistakes; the official description above is the record.
