CVE-2020-15180 Command injection in mariadb
Remote attackers can execute arbitrary commands on MariaDB Galera cluster nodes via command injection in the wsrep_sst_method component.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2020-15180?
CVE-2020-15180 is a critical command injection vulnerability in Debian Debian Linux, published on 27 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A flaw was found in the mysql-wsrep component of mariadb. Lack of input sanitization in `wsrep_sst_method` allows for command injection that can be exploited by a remote attacker to execute arbitrary commands on galera cluster nodes. This threatens the system's confidentiality, integrity, and availability. This flaw affects mariadb versions before 10.1.47, before 10.2.34, before 10.3.25, before 10.4.15 and before 10.5.6.
Which versions are affected by CVE-2020-15180?
3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 4 products.
| Package | Affected | Fixed in |
|---|---|---|
mariadb Bitnami | From 10.1.0 | 10.1.47, 10.2.34, 10.3.25, 10.4.15, 10.5.6 |
mariadb-min Bitnami | From 10.1.0 | 10.1.47, 10.2.34, 10.3.25, 10.4.15, 10.5.6 |
mysql-client Bitnami | From 10.1.0 | 10.1.47, 10.2.34, 10.3.25, 10.4.15, 10.5.6 |
Linux distribution packages (4)
mariadb-galera Red Hat:openstack:10::el7 | All versions | 1:5.5.62-2.el7ost |
mariadb-galera-common Red Hat:openstack:10::el7 | All versions | 1:5.5.62-2.el7ost |
mariadb-galera-debuginfo Red Hat:openstack:10::el7 | All versions | 1:5.5.62-2.el7ost |
mariadb-galera-server Red Hat:openstack:10::el7 | All versions | 1:5.5.62-2.el7ost |
Products include Debian Debian Linux, Galeracluster Galera Cluster for Mysql, Mariadb Mariadb, Percona Xtradb Cluster.
How do I fix CVE-2020-15180?
Upgrade mariadb to a fixed version for your release line: 10.1.47, 10.2.34, 10.3.25 or 10.4.15.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2020-15180 being exploited?
There is no known exploitation of CVE-2020-15180 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as ALPINE-CVE-2020-15180, BIT-mariadb-2020-15180, BIT-mariadb-min-2020-15180, BIT-mysql-client-2020-15180, DEBIAN-CVE-2020-15180, DLA-2409-1 and 4 more.