# CVE-2020-15180: Command injection in mariadb

> Remote attackers can execute arbitrary commands on MariaDB Galera cluster nodes via command injection in the wsrep_sst_method component.

- **Severity:** Critical 9.0 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2021
- **Updated:** 4 Aug 2024
- **Also known as:** ALPINE-CVE-2020-15180, BIT-mariadb-2020-15180, BIT-mariadb-min-2020-15180, BIT-mysql-client-2020-15180, DEBIAN-CVE-2020-15180, DLA-2409-1, DSA-4776-1, MGASA-2020-0382, RHSA-2020:5379, UBUNTU-CVE-2020-15180

## What is CVE-2020-15180?

CVE-2020-15180 is a critical command injection vulnerability in Debian Debian Linux, published on 27 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A flaw was found in the mysql-wsrep component of mariadb. Lack of input sanitization in `wsrep_sst_method` allows for command injection that can be exploited by a remote attacker to execute arbitrary commands on galera cluster nodes. This threatens the system's confidentiality, integrity, and availability. This flaw affects mariadb versions before 10.1.47, before 10.2.34, before 10.3.25, before 10.4.15 and before 10.5.6.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2020-15180?

3 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client. It affects 4 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mariadb` | Bitnami | From 10.1.0 | 10.1.47, 10.2.34, 10.3.25, 10.4.15, 10.5.6 |
| `mariadb-min` | Bitnami | From 10.1.0 | 10.1.47, 10.2.34, 10.3.25, 10.4.15, 10.5.6 |
| `mysql-client` | Bitnami | From 10.1.0 | 10.1.47, 10.2.34, 10.3.25, 10.4.15, 10.5.6 |
| `mariadb-galera` | Red Hat:openstack:10::el7 | All versions | 1:5.5.62-2.el7ost |
| `mariadb-galera-common` | Red Hat:openstack:10::el7 | All versions | 1:5.5.62-2.el7ost |
| `mariadb-galera-debuginfo` | Red Hat:openstack:10::el7 | All versions | 1:5.5.62-2.el7ost |
| `mariadb-galera-server` | Red Hat:openstack:10::el7 | All versions | 1:5.5.62-2.el7ost |

Products: Debian Debian Linux, Galeracluster Galera Cluster for Mysql, Mariadb Mariadb, Percona Xtradb Cluster.

## How do I fix CVE-2020-15180?

Upgrade mariadb to a fixed version for your release line: 10.1.47, 10.2.34, 10.3.25 or 10.4.15.

## Is CVE-2020-15180 being exploited?

There is no known exploitation of CVE-2020-15180 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15180 and fix it if it is affected.

What it is: CVE-2020-15180 is a critical command injection vulnerability in Debian Debian Linux, published on 27 May 2021. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2020-15180 in the wild and no public exploit code.

Affected packages and fixed versions:
- mariadb (Bitnami): affected from 10.1.0; fixed in 10.1.47, 10.2.34, 10.3.25, 10.4.15, 10.5.6
- mariadb-min (Bitnami): affected from 10.1.0; fixed in 10.1.47, 10.2.34, 10.3.25, 10.4.15, 10.5.6
- mysql-client (Bitnami): affected from 10.1.0; fixed in 10.1.47, 10.2.34, 10.3.25, 10.4.15, 10.5.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15180/ (Markdown: https://insights.sbomify.com/CVE-2020-15180/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15180
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15180
- OSV: https://osv.dev/vulnerability/CVE-2020-15180

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15180/
Summaries are generated and may contain mistakes; the official description above is the record.
