# CVE-2020-15181: Admin account takeover in Alfresco Reset Password


- **Severity:** Critical 9.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 18 Sep 2020
- **Updated:** 4 Aug 2024
- **Also known as:** GHSA-xrc8-fjp4-h4fv

## What is CVE-2020-15181?

CVE-2020-15181 is a critical vulnerability in FlexSolution AlfrescoResetPassword, published on 18 Sep 2020. 

### Official description

The Alfresco Reset Password add-on before version 1.2.0 relies on untrusted inputs in a security decision. Intruders can get admin's access to the system using the vulnerability in the project. Impacts all servers where this add-on is installed. The problem is fixed in version 1.2.0

Weakness: CWE-284 (Improper Access Control), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2020-15181?

It affects 1 product.


Products: Alfresco Reset Password.

## How do I fix CVE-2020-15181?

No fix has been published for CVE-2020-15181 yet. Limit exposure of the affected software until one is available.

## Is CVE-2020-15181 being exploited?

There is no known exploitation of CVE-2020-15181 in the wild and no public exploit code.

## Other vulnerabilities in FlexSolution AlfrescoResetPassword

- [CVE-2020-25728](https://insights.sbomify.com/CVE-2020-25728/): Business logic in n/a (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15181 and fix it if it is affected.

What it is: CVE-2020-15181 is a critical vulnerability in FlexSolution AlfrescoResetPassword, published on 18 Sep 2020. 
Exploitation: There is no known exploitation of CVE-2020-15181 in the wild and no public exploit code.

Affected product: FlexSolution AlfrescoResetPassword. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15181/ (Markdown: https://insights.sbomify.com/CVE-2020-15181/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15181
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15181
- OSV: https://osv.dev/vulnerability/CVE-2020-15181

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15181/
Summaries are generated and may contain mistakes; the official description above is the record.
