# CVE-2020-15186: Improper sanitization of plugin names in Helm

> Malicious Helm plugin authors can spoof help output or duplicate names due to improper sanitization, requiring users to upgrade Helm.

- **Severity:** Low 3.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 17 Sep 2020
- **Updated:** 4 Aug 2024
- **Also known as:** BIT-helm-2020-15186, GHSA-m54r-vrmv-hw33

## What is CVE-2020-15186?

CVE-2020-15186 is a low-severity vulnerability in helm, published on 17 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In Helm before versions 2.16.11 and 3.3.2 plugin names are not sanitized properly. As a result, a malicious plugin author could use characters in a plugin name that would result in unexpected behavior, such as duplicating the name of another plugin or spoofing the output to `helm --help`. This issue has been patched in Helm 3.3.2. A possible workaround is to not install untrusted Helm plugins. Examine the `name` field in the `plugin.yaml` file for a plugin, looking for characters outside of the [a-zA-Z0-9._-] range.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2020-15186?

5 open source packages ship an affected version, including helm.sh/helm, helm and helm.sh/helm/v3. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `helm.sh/helm` | Go | All versions | 2.16.11 |
| `helm.sh/helm` | Go | All versions | 2.16.11 |
| `helm` | Bitnami | From 2.0.0 | 2.16.11, 3.3.2 |
| `helm.sh/helm/v3` | Go | From 3.0.0 | 3.3.2 |
| `helm.sh/helm/v3` | Go | From 3.0.0 | 3.3.2 |

Products: Helm Helm.

## How do I fix CVE-2020-15186?

Upgrade helm.sh/helm to 2.16.11 or later.

## Is CVE-2020-15186 being exploited?

There is no known exploitation of CVE-2020-15186 in the wild and no public exploit code.

## Other vulnerabilities in helm

- [CVE-2019-18658](https://insights.sbomify.com/CVE-2019-18658/): Helm Unsafe Link Following (critical 9.8)
- [CVE-2019-1010275](https://insights.sbomify.com/CVE-2019-1010275/): Helm Improper Certificate Validation (critical 9.8)
- [CVE-2019-25210](https://insights.sbomify.com/CVE-2019-25210/): Information disclosure in n/a (critical 9.1)
- [CVE-2025-53547](https://insights.sbomify.com/CVE-2025-53547/): Helm Chart Dependency Updating With Malicious Chart.yaml Content And Symlink Can Lead To Code Execution (high 8.5)
- [CVE-2020-11013](https://insights.sbomify.com/CVE-2020-11013/): lookup Function Information Discolosure in Helm (high 8.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2020-15186 and fix it if it is affected.

What it is: CVE-2020-15186 is a low-severity vulnerability in helm, published on 17 Sep 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2020-15186 in the wild and no public exploit code.

Affected packages and fixed versions:
- helm.sh/helm (Go): affected all versions; fixed in 2.16.11
- helm.sh/helm (Go): affected all versions; fixed in 2.16.11
- helm (Bitnami): affected from 2.0.0; fixed in 2.16.11, 3.3.2
- helm.sh/helm/v3 (Go): affected from 3.0.0; fixed in 3.3.2
- helm.sh/helm/v3 (Go): affected from 3.0.0; fixed in 3.3.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2020-15186/ (Markdown: https://insights.sbomify.com/CVE-2020-15186/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2020-15186
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2020-15186
- OSV: https://osv.dev/vulnerability/CVE-2020-15186

---
From sbomify Insights: https://insights.sbomify.com/CVE-2020-15186/
Summaries are generated and may contain mistakes; the official description above is the record.
