{"answers":{"affected":"5 open source packages ship an affected version, including helm.sh/helm, helm and helm.sh/helm/v3. It affects 1 product.","exploited":"There is no known exploitation of CVE-2020-15187 in the wild and no public exploit code.","fix":"Upgrade helm.sh/helm to 2.16.11 or later.","what":"CVE-2020-15187 is a low-severity vulnerability in helm, published on 17 Sep 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2020-15187 and fix it if it is affected.\n\nWhat it is: CVE-2020-15187 is a low-severity vulnerability in helm, published on 17 Sep 2020. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2020-15187 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- helm.sh/helm (Go): affected from 2.0.0; fixed in 2.16.11\n- helm.sh/helm (Go): affected from 2.0.0; fixed in 2.16.11\n- helm (Bitnami): affected from 2.0.0; fixed in 2.16.11, 3.3.2\n- helm.sh/helm/v3 (Go): affected from 3.0.0; fixed in 3.3.2\n- helm.sh/helm/v3 (Go): affected from 3.0.0; fixed in 3.3.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2020-15187/ (Markdown: https://insights.sbomify.com/CVE-2020-15187/index.md)","id":"CVE-2020-15187","markdown":"https://insights.sbomify.com/CVE-2020-15187/index.md","name":"CVE-2020-15187","record":{"aliases":["BIT-helm-2020-15187","GHSA-c52f-pq47-2r9j"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Helm package manager","requires_auth":"low_privilege","summary":"Compromised Helm plugins with duplicate entries allow attackers to modify install hooks, leading to local code execution during plugin installation.","user_interaction":"required","vuln_class":"supply_chain"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"helm","vendor":"helm"}],"cvss":{"score":3,"severity":"low","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-74","name":"Improper Neutralization of Special Elements in Output Used by a Downstream Component"},{"id":"CWE-694","name":"Use of Multiple Resources with Duplicate Identifier"}],"description":"In Helm before versions 2.16.11 and 3.3.2, a Helm plugin can contain duplicates of the same entry, with the last one always used. If a plugin is compromised, this lowers the level of access that an attacker needs to modify a plugin's install hooks, causing a local execution attack.\nTo perform this attack, an attacker must have write access to the git repository or plugin archive (.tgz) while being downloaded (which can occur during a MITM attack on a non-SSL connection). This issue has been patched in Helm 2.16.11 and Helm 3.3.2.\nAs a possible workaround make sure to install plugins using a secure connection protocol like SSL.","ecosystems":["Bitnami","Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Duplicate plugin entries in Helm","id":"CVE-2020-15187","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"supply_chain","year":"2020"},"n_packages":5,"n_references":7,"next":{"headline":"Unauthenticated Remote Code Execution in SOY CMS","id":"CVE-2020-15188"},"packages":[{"ecosystem":"Bitnami","fixed":["2.16.11","3.3.2"],"introduced":["2.0.0","3.0.0"],"last_affected":[],"package":"helm","purl":"pkg:bitnami/helm","source":"BIT-helm-2020-15187"},{"ecosystem":"Go","fixed":["2.16.11"],"introduced":["2.0.0"],"last_affected":[],"package":"helm.sh/helm","purl":null,"source":"GHSA-c52f-pq47-2r9j"},{"ecosystem":"Go","fixed":["2.16.11"],"introduced":["2.0.0"],"last_affected":[],"package":"helm.sh/helm","purl":"pkg:golang/helm.sh/helm","source":"GHSA-c52f-pq47-2r9j"},{"ecosystem":"Go","fixed":["3.3.2"],"introduced":["3.0.0"],"last_affected":[],"package":"helm.sh/helm/v3","purl":null,"source":"GHSA-c52f-pq47-2r9j"},{"ecosystem":"Go","fixed":["3.3.2"],"introduced":["3.0.0"],"last_affected":[],"package":"helm.sh/helm/v3","purl":"pkg:golang/helm.sh/helm/v3","source":"GHSA-c52f-pq47-2r9j"}],"prev":{"headline":"Improper sanitization of plugin names in Helm","id":"CVE-2020-15186"},"products":["helm"],"published":"2020-09-17","related":[{"cvss_score":9.8,"headline":"Helm Unsafe Link Following","id":"CVE-2019-18658","kev_date_added":null,"published":"2019-11-12"},{"cvss_score":9.8,"headline":"Helm Improper Certificate Validation","id":"CVE-2019-1010275","kev_date_added":null,"published":"2019-07-17"},{"cvss_score":9.1,"headline":"Information disclosure in n/a","id":"CVE-2019-25210","kev_date_added":null,"published":"2024-03-03"},{"cvss_score":8.5,"headline":"Helm Chart Dependency Updating With Malicious Chart.yaml Content And Symlink Can Lead To Code Execution","id":"CVE-2025-53547","kev_date_added":null,"published":"2025-07-08"},{"cvss_score":8.5,"headline":"lookup Function Information Discolosure in Helm","id":"CVE-2020-11013","kev_date_added":null,"published":"2020-04-24"},{"cvss_score":8.4,"headline":"Helm has a path traversal in plugin metadata version enables arbitrary file write outside Helm plugin directory","id":"CVE-2026-35204","kev_date_added":null,"published":"2026-04-09"},{"cvss_score":8.4,"headline":"Helm's plugin verification fails open when .prov is missing, allowing unsigned plugin install","id":"CVE-2026-35205","kev_date_added":null,"published":"2026-04-09"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2025-05-29","vendors":["helm"]},"summary":"Compromised Helm plugins with duplicate entries allow attackers to modify install hooks, leading to local code execution during plugin installation.","url":"https://insights.sbomify.com/CVE-2020-15187/"}